MyVolumio bug reports

Please let’s use this thread as a flow of information about bugs and inconsistencies found during using MyVolumio (for the beta phase only).
This will serve as bug tracker and will maximize our awareness of the open issues.

Please try to report as many informations as you can, together with screenshots where possible.

List of known bugs:

  • Avoid the error popup when internet is not available on UI side
  • Fix the naming inconsistency (related to Volumio more than MyVolumio)
  • We need to ask explicitly upon first activation to users to set up a password for their account.
  • Make MyVolumio builds detectable by Android app
  • Upon account deletion ,any active subscription must be cancelled
  • Fix QOBUZ and TIDAL sorting of added tracks
  • Restore notification of random\repeat
  • Complete album banner on TIDAL
  • Impossible to add my webradios


  • Add quality selection for TIDAL
  • Add favourites handling on TIDAL

List of solved bugs:

  • Form validation is too strict for passwords and user names
  • Improved regex for password validation, to allow complex passwords to be set (to be further improved)
  • QOBUZ Icon
  • Restore local browser compatibility
  • Allow more than 50 items on QOBUZ listings
  • Use a better explanation for missing streaming services on MyVolumio
  1. On connecting to hotspot on first boot, I get:

MYVOLUMIO ERROR Error loading script

After clicking on ‘ok’, everything seems to proceed correctly.

  1. Host name set as “Myvolumio_test” is correct in /etc/hostname, but displays as “Volumio” in Multiroom devices. Presumably problem is the underscore as “testmyvolumio” displays correctly.


Thanks Ian, added to bug list!

When signing up on MyVolumio site, I got a validation error “password format incorrect” or similar. The allowed password format wasn’t shown, so I had to try multiple times, in the end settling for a password with no capitals, symbols or numbers!

When volumio booted for the first time after I flashed the sd with the new image, the MyVolumio menu option was not visible. Also the ‘First run wizard’ didn’t run. After I configured my I2C DAC, DSP and Sampling (requiring a few reboots), the wizard appeared after the 2nd or 3rd reboot. When the wizard was completed the MyVolumio options appeared.

I have a very quick listen to Qobuz streaming which sounded good. After a few tracks of the playlist, the metadata stopped being updated.

Now I’m wondering if the two bugs above were caused by cached front end files. I will try a hard refresh later and see if that helps.

The limit of items on displayed on ‘My Albums’ looks to be too small (without paging).

Yes, they are most likely caused by caching on the browser.
Thanks for the precious feedback!

Hi Guys. Yessss! got my mail from Qobuz today.
Downloaded and unzipped image.
Flashed image to SIM.
Install started.
Unable to complete wireless setup. Skipped that in the end and continued.
Attempted to login to MyVolumio. Filled email address and password. PW error - Match the requested format. Checked my PW - it is correct.
Attempted the PW reset. Filled in my email and hit RESET. Error - there is no user record corresponding to this identifier. The user may have been deleted.

Logged in to the desktop at and checked my profile. Definitely the correct email address.

Tried a fresh sign up. Used existing user name and email address. Changed password. All OK Verification email sent and this worked.
Logged in and out OK.
Looked for Qobuz - worked out I had to change plan.
Changed to single device plan. Links worked and input voucher code I was sent by Qobuz. All OK Search function etc all initially looks like it works. I could see playback start on the piano. Not connected to audio as wired to hub.
Having a few teething problems with wireless connection, but I think that is just an error in my setup.

Cheers - Chris.

Yes you need a new account for myvolumio, we will unify them in the future

Thank you.

All working. Playback from Qobuz works fine.
Track timer on app and gui is not keeping in sync. Noticeable if phone goes to sleep, or you flick between pages.
Track art and title display not updating.
Web radio is white noise :smiley:

Regards: Chris.

Just to let you know I’ve got everything working so far.
Took ages to set up as I was unable to set up wireless network passcode using my pixel phone. This is a page formating fault that wasn’t there on earlier volumio. Solved by using my windows pc and wired network to set WiFi password.

Haven’t worked out why I would pay a subscription in future as Bubbleupnp does Tidal, Google play etc. But want to help as a volumio user for about 3 years. Tidal 24bit (mqp) support might be worth a small fee?
Biggest ball ache is WiFi speed, sometimes 200mb/s, great for dsd, sometimes 72mb/s or lower, not good for hi Res audio. This may be my network issue though.

Setup: Pi3+, Allo digione, Chord Mojo, 300B SE valve amps.

Installation went well but I haven’t received any confirmation mail and it doesn’t seems work when I request for a new confirmation mail.
request for a new (forgotten) password works


Opps !
Microsoft thinks it a spam mail
I’m using and mail address/account

qobuz does not appear on safari despite the refreshing (see capture).


the integration of qobuz work very well, thanks for the very good job.

the plugin touchscreen install correctly but i does not connected to the web server.


I’m getting spinning wheel while trying to login to myvolumio. Localy I access Volumio without any issue. My user account is sutr01.


This has been fixed in the new version

Hi Martin, can you try to reboot your pi and let us know if the issue persists?


I did that, but it didn’t helped. Funny I could access the profile from local site. I also removed my second device in the office from the profile, but it didn’t help either.

Could be the reason for this that when I installed volumio for the first time I was on WiFi & then I changed to wired network - I tried to go back but it didn’t helped.

So still I can access profile from local network via technics.local but can’t via


No, we’re experiencing some issues on the central dispatcher. We’re investigating.
Thanks for your report!

First, congrats for this Qobuz integration, I was dreaming of it for a while now!

Small issue to report:

  • Since Saturday (at least I experienced it first on Saturday), when starting a qobuz playlist, while the right album cover is displayed, the music played is the first song on my NAS (alphabetical order). And when I select another play list, the same happens.
    Moving (with the arrow) to the next song on the playlist, plays correctly the second playlist’s song.

  • it seems like each time there is a network or read error in the qobuz stream, the player plays the first file on the NAS. The GUI show the cover of the expected song. Pushing on skip to the next file, brings the player back to the qobuz playlist. Until the next error.

Tell me if I you would like me to send logs or other information.

Thank you!

Same behaviour here. Reboot does not fix it.
I can play the music accessing the local UI.

Same behaviour for me.