Mytek 192 DSD DAC driver issue


with the support of Michelangelo and the work of Lintweaker I finally compiled the kernel module needed to get the Mytek 192 DSD Dac to work with Volumio. Almost.

dmesg shows that the module load without errors and the DAC makes a lock with the USB 2 port connected. However, when starting playback, Volumio gives an

Error, Failed to open audio output

message. Dmesg after the playback attempt reports

usb 1-1.4: error stopping streaming while setting samplerate 44100

Anybody an idea why that? Might it be a mpd configuration issue that could be fixed somhow or is it the kernel module itself?

On my Ubuntu Laptop the playack caused no issues using this driver.

If anybody is interested to try the Mytek DAC with Volumio, just le me know, I’ll be happy to pass the kernel module

Try to enable resampling on mpd, maybe this driver has some issues on redbook quality… Let me know I’m very interested…

Also, clivem, which is around here from time to time, knows something about this driver… Maybe he will help…

tried it with resampling, => no sucess.

dmesg gives

usb 1-1.4: error stopping streaming while setting samplerate xxxxxx whatever samplerate I tried

mpd is configured like

[code]audio_output {

name “Mytek_DAC”
type “alsa”
device “hw:1,0”


aplay -l gives

card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]
  Subdevices: 8/8
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
  Subdevice #2: subdevice #2
  Subdevice #3: subdevice #3
  Subdevice #4: subdevice #4
  Subdevice #5: subdevice #5
  Subdevice #6: subdevice #6
  Subdevice #7: subdevice #7
card 0: ALSA [bcm2835 ALSA], device 1: bcm2835 ALSA [bcm2835 IEC958/HDMI]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: USB2 [Mytek Stereo192-DSD USB2], device 0: MytekUSB2 [Mytek USB2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

mpd log when trying to playback:

Nov 22 18:46 : alsa_output: Failed to open "USB Audio DAC" [alsa]: Error opening ALSA device "hw:1,0" (snd_pcm_hw_params): Connection timed out
Nov 22 18:46 : output: Failed to open audio output
Nov 22 18:46 : player: problems opening audio device while playing "NAS/Public/Test.flac"


Bus 001 Device 014: ID 25ce:000e  
Bus 001 Device 004: ID 0cf3:7015 Atheros Communications, Inc. TP-Link TL-WN821N v3 802.11n [Atheros AR7010+AR9287]
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

the DAC is device 014, but no name is shown here. Could this be a hint whats going wrong?

I gave up at this point, input heavily requested :wink:

Try to manually modprobe (with sudo) the kernel module you just built…

no success with manually load the kernel module.

I used

and then it played the file. but only one time. tried to reproduce it, but no success, even after 10 times reproducing the steps. strange thing.

at least, it demonstartes that there might be a way to use the DAC with volumio.

still, the DAC works flawlessly under ubuntu using the same driver. so i guess it has to be something rpi specific.

maybe somone with deeper knowledge can bring more input.

The driver works, I know that much. I also know that people have used the DAC with the RPi on Debian/Raspbian. I’ll reach out to someone I know with the DAC and see if he can help you. I doubt whether he uses VolumIO. I suspect he won’t have even heard of VolumIO, but I will try.

Thanks Clive, that’s really appreciated!

Thanks clivem, that sounds promising!

today I failed to get the DAC to work with latest rasbian. same behavior as with volumio.

so maybe the info clivem is trying to bring in from the guy using the DAC with raspbian will also help for volumio

Keep us posted, I think we will make it work hopefully!

so here’s an update about the mytek driver issues.

finally I got it to work (more or less), I just switched from rpi2 to rpi3, because I observed some buffer underruns on the rpi2, just wanted to see how same setup performs on pi3. It’s now playing files up to 192khz and even DSD over PCM, but sound quality is extra bad, glitches all the time and even some strange pitching during playback from time to time, which I’ve never heard on any digital device so far. Native DSD (without dop) is played back in 192khz, which is sort of strange, too.

mpd is configured like

audio_output { type "alsa" name "alsa" device "hw:1,0" dop "no"

where hw:1,0 is

    Mytek Stereo192-DSD USB2, Mytek USB2
    Direct hardware device without any conversions

first I suspected some conversion is going on somewhere, and the rpi3 might not be capable of doing this proper on the fly, but at least is capable of playing with bad quality, unlike to the rpi2 which completely failed. Then I stressed the cpu to almost 100% with another process while playback, but sound quality didn’t get worse by that, so cpu seems to be not a factor. Also system load is quite low while playing back.

still, any input highly appreciated…

It’s the good old USB Bus issue of the PI: … ues-on-pi/

Try to add:

to /boot/cmdline.txt

Altough I don’t think it will fix the issue on current kernel, but worth trying…
Let me know

you were right…


didn’t do anything :neutral_face:

Are you playing your files from NAS or USB?

It’s all coming from a NAS

I guess we’re asking too much to the USB bus of the PI.
Can you tell me if you get the same with 44.1\16 files?

It’s more or less the same issues with 44,1 192 and DSD over PCM, maybe a little better with lower sample rate, but not that it is pointing in any direction. When I’m back from work in 3 days, I’ll have a closer look whats going on, lets see what happens when I use airplay or usb device…
still strange that it didn’t work at all on the raspberry pi 2, and now it’s playing even 192khz on the pi 3. for me, this points to a performance issue