My house full of Volumio and Cubox-i4s

Good day to all,

I wanted to take a moment to talk about my experiences with Volumio and Cubox-i4 computers.

My first Volumio project was a “trial run” on our main home music server, which is a Cubox-i4 that I bought in spring 2014 and on which I ran Voyage Mubox. I was generally pretty satisfied with Mubox except for two things: I could not get wifi working, which at the time was a kind of theoretical problem, as I managed to get an ethernet cable to it; and I kind of wanted a good web interface so that I didn’t have to install client software on every computer and telephone in our household.

So when I read that Volumio 1) ran on the Cubox-i computers, 2) had a decent web interface, 3) was Debian-based and 4) had a kernel that supported wifi, I decided to give it a go. First, I installed it on the main music server as I mentioned above. In this configuration, I used a 2TB eSata hard drive from LaCie and a Schiit Bifrost Uber, which connects into the home stereo, a collection of Linn boxes and speakers.

My first reactions to this were somewhat varied.

The download and install process was simple and straightforward (I am a Linux-only guy). The box came up without a problem; I was able to access both the web interface and ssh command line easily. All good so far.

Getting the eSata disk mounted and recognized was somewhat frustrating. I followed the instructions elsewhere on this site (create /mnt/ESATA, etc) and got the drive mounted without a problem, but if memory serves it took a number of reboots and library updates on the web interface before I actually began to see the music.

At some point I made the mistake of editing various Linux configuration files (like /etc/network/interfaces for example) and eventually realized that was NOT TO BE DONE, when I discovered the php code overwriting those files. I think this happened when I was trying to test out wi-fi and I could not configure the wi-fi the way I wanted through the web interface (static IP etc). By this time the system was getting kind of mangled so I re-installed from scratch and only touched the configuration via the web interface.

And from there onward, I just used it, and all worked very well. One thing that troubled me for awhile was the very small icons for managing content on the browse screen, jammed over against the right hand side. This didn’t work well on a mobile device browser. Also I noticed that I could only add songs, not albums. So eventually, I went back to using MPDroid but now talking to the Volumio machine rather than Voyage.

I might add that the music chain Cubox-i4 + Volumio -> Schiit Bifrost -> Linn Kolektor seemed extremely musical and involving. Great stuff in the living room.

Earlier this year, my wife mentioned that she was getting tired of the big old Sony amplifier and CD changer in the bedroom, and so I ordered a second Cubox-i4 and repurposed a 1TB hard drive in an eSata box, an AudioQuest DragonFly and a Parasound ZAmp I had sitting around.

Unfortunately this experience was full of negatives. The first negative was that the so far untested ethernet cable running to that room was I guess damaged during installation, because it won’t permit a connection to the house network. So we were forced to go to wireless, and that led to much experimentation.

What seems to be the case is that the 3.14.14 kernel in Volumio 1.5 “only kind of” works with the networking hardware in the Cubox-i4. That is, the network comes up and runs for awhile, maybe an hour or so, but then just goes away. ifconfig on the Cubox-i4 seems to think the connection remains live, but pings go nowhere and it’s not possible to get in from the outside.

As it happens, the second Cubox-i4 had a defective eth0 which would not maintain an electrical connection, so the good people at SolidRun did an RMA for me (great great service from them by the way) and a replacement (Cubox-i4 n° 3) arrived.

Same problem with the wi-fi, but now at least I had a working eth0; but with nothing to connect it to in the room… so I bought an ASUS RT-N12D1 to work as a wireless bridge into that room. And finally, we have a Cubox-i4 with a 1TB drive and lots of great music on it all accessible over the network.

Sounds perfect, right? Well not quite. The last problem remaining to solve (for now!) is that the DAC used, an AudioQuest DragonFly 1.0, is not quite compatible with the 3.14.14 kernel on the machine. There are other reports of this elsewhere on this site, but in my case the exact issues are that the DragonFly seems to cause errors when playing 44.1/16 music, but not for example 96/24 music. This is heard as an occasional extremely brief burst of static or a pop, somewhat like a noisy LP on a turntable, accompanied by the message “cannot get freq at ep 0x1”.

This “cannot get freq pop” can be reduced by fiddling with the various settings. Right now I have the buffer at 10% and am using the ACX kernel parameters, which seems to almost eliminate the problem. Almost. I see postings of similar issues around the web, in particular an interesting discussion over on Launchpad that seems to indicate that this problem was introduced in 3.8 or so kernels and may be gone in the latest. Also, on the alsa users list there is some indication that it may be a firmware error in the DAC itself, though since similar problems (noise plus that message) appear in relation to other DACs I’m not sure I fully believe that.

So one day when I have some time, I might try to build a new kernel for that machine.

As a side comment, it seems to me that the icons for managing music content on the browse screens are better in the new installation, so perhaps someone has had a go at this?

To close then: generally, I am really happy with Volumio. I like having the option of a web interface, not just MPDroid (or other smartphone app) or Sonata (or other Linux desktop application). And Volumio’s web interface seems really nice.

If I could change anything in Volumio, I think I would make the wireless configuration a bit richer (permit static IP and select channel manually, for example). Also, I would give some thought to reading the Linux config files, not just overwriting them. But these are pretty minor points.

More important than that, it would be nice to see a newer kernel, perhaps 3.19 or 4.1 even. Again, not a deal-breaker, but when something doesn’t work, like the DAC for instance, the first troubleshooting always seems to be “try a newer kernel”.

So, to the Volumio team, thank you for a very good piece of work. Recommended to all.


I’m using a Cubox i4 Pro LE (1.2ghz) as well as the Dragonfly 1.0. I’ve experienced the same popping issues that you described and solved it by using a powered Belkin USB hub between the Cubox and the Dragonfly. Everything works fine with the hub in place. IIRC the issue was due to the timing of the data frame/packets when running the USB 1.0 async Streamlength code (I hope I kinda got this right). The credit goes to Triode over on the Squeezebox forums.

Here’s hoping that the Cubox gets more support since I believe it’s more powerful than the Pi. =)