My first Volumio streamer won't work


I just built my first dream streamer based on raspberry pi 3 b + Hifiberry Digi.

However, I have a big problem. Installs volumio according to the instructions on the site. I configure everything nicely, connect to wifi etc. However, after turning it off and connecting it again, it does not want to load http: //volumio.local and the volumio application on the phone does not find the device. Reinstalling the system and configuration works, then again when I connect the raspberry pi to my system, I can’t connect to it again, after turning Raspberry off. Sometimes it appears as a hotspot for a while. What am I doing wrong?

Edit: When im connecting hdmi cable then WebUi and app instantly starts and everything looking ok, but then im trying to play something in Spotify using Spotify Connect and it is so laggy. Waiting for song for about 2-3 minutes, and its stops… and then i can’t Connect to the volumio again… what is going on guys?! AirPlay wont work too… im thinking that my investment in Raspberry pi streaming was big mistake…

Edit 2: changing wifi connection from 2.4 GHz to 5 GHz solved issue. Everything is slow still but it is working now. Weird. I have many wifi devices in same płace and zero problems (old streamer) etc. So it is bad wifi in Raspberry pi problem? Why it cant handle 2.4 GHz? For example on the same desk i have ps4 and playing heavy games online with 2.4ghz. Its looks like volumio software have problems (newest version)

better way is to use the ip of your device volumio.local is not always working.
if wifi isn’t working for you could try a wired version so add a utp cable.
in some versions wifi will switch off after reboot and try a static ip
the pi3 b shares the usb and wan connection pi4 doesnt
( please always post the volumio version and dont use the (newest version) one week later it’s it isn’t any more )

and please post your Send Log or bug report, you can reach that with
http://volumio.local/dev or http:// < your ip > /dev

Hi thanks,

I have static IP, i try connecting thru IP (same), i dont have possibility to connecting thru ethernet (router is in other płace in the home). I tried to download other version of volumio but there is no other version (than newest) on the page :frowning:

For now Raspberry Pi is in 5 GHz network, other devices in 2.4 GHz and everything working, but Spotify in volumio app loading about 15 seconds. So there is for sure problem with the software. I think i will try moode audio.

This seems to suggest more an issue with the network setup – try sharing some system logs please?

Preferable from a fresh reboot, with minimal steps to reproduce the problem :slight_smile:

Thank you but i dont know how to do it :disappointed: This is my first Pi.

Oh today i opening volumio app and bum another problem. Cant open Spotify. Error like in the picture.

Edit: after turning I2S dac (which i dont have) Spotify working again :flushed:

:rage::rage: I never had so many problems with one software - for know i think Volumio is simply buggy as hell.

Did you try clicking that link? It’s all directly from the browser.

This is again pointing towards a network error – most streaming things require stable network connection.

Sorry you feel that way, this isn’t normally the case – but if you’d like to have a more pleasant experience, try fixing your network issue…

Ok thank you, I will send Bug report.

But for now one is for sure: In my router i Creat two wifi connections 5ghz and 2.4 GHz. On 2.4 GHz volumio showing speed 60mb/s and after restart i cant even open UI. When switching to 5ghz, speed in volumio app showing 180 Mb/s and then everything works (Ui, Spotify Connect etc). So it looks like 2.4 GHz in my room is too slow for volumio and that was the whole problem.

(In fact my internet connection is static 30 Mb/s So i dont where volumio finds this 180 or even 60 Mb/s).

But guys… On my tv i streaming 4K movies with that 2.4ghz, and on ps4 i playing online games in the same room. And this is only a small audio streamer :flushed: Why its need So much internet?

That’s the theoretical speeds for the WiFi that your router can support, so it is the speed of your internal network and not the internet connection.

Edit: You can use apps like Fing or Wifiman to check if there is a lot of neighbours that has Wifi-networks on the same channels as your 2.4/5 GHz and then change the channels to improve your signal.

You TV also has a nice big antenna, but the small Pi does not :slight_smile: – the issue is not the bandwidth, but connectivity. If the connection keeps dropping packets, you might run into issues…

I can only reffer to my experiences, but since I also stumbled upon the problem mentioned byt the OP, a piece of advice: change your connection to cable (LAN). It solved my issues.

I have no idea why Volumio operates over wifi in an unstable manner. I did everything to make it work (I’m more than qualified to do pro networking stuff), but I abandoned the wifi altogether.
LAN works very well on the other hand.

the pi’s have a little antenne build onboard that’s why if there are many things that use wifi they could give a weak signal a cable doesn’t have that problem. if your handy you could make it a external antenne

That’s not the case in case of Raspis. I have a couple of them which I use for different projects and I can assure you that: 1) the connection stability with Raspis is very good, 2) range is poor.

There’s something else going on with how Volumio is configured by default that generates problems with wifi on Raspis, it’s not common knowledge, therefore plenty of people report wifi issues like that on the forum.
I’d like the Volumio team to talk about it more openly.
I’d like the OP to be aware that it’s not his fault in any way.
I’ve experienced the problem myself and abandoned wifi option despite having enough knowledge of both networking and Linux. Maybe in the future I’ll try external USB wifi dongles I could recommend with Volumio.

Your advice, though, is a very good heuristic to apply by default.

i started with the pi4 i have 2 of those they got better connection. tnx glad it worked.

I found a solution - moode audio, hifiberryOS. Its just works out of the box. Volumio need to much internet in my opinion

volumio is oke if you worked with it. i started in corona time with it learned a lot and yes volumio has a learning curve, but in the end you have a nice player with a lot more options…

btw if your handy you could add a external antenna :

I found the solution on raspberry pi forum:

This solved WiFi problems for me:
sudo iwconfig wlan0 power off

I added that line to /etc/rc.local (before “exit 0”) so that it would get executed on startup.

(I also upgraded the software:
sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade

This topic is about the same:

But my problem is that im not a computer guy, and I have no idea where to put this codes etc :frowning:

Maybe some goo soul good write some small instruction step by step how to do it ?

@mateolo2 i will give you one advice never do a sudo upgrade this will corrupt your volumio.
update you can do always.