My experience so far, a quickie on Volumio and RPI3

G’day folks,

just trying out Volumio for a few hours, still need to make up my mind, it took so long to get started that I’d like to share what worked for me.

My setup is a Raspberry Pi 3, wireless, using an external USB DAC based on the Amanero USB Combo board.

First, setup the wifi.

On a fresh install, connect with your laptop to the Volumio hotspot (PW: volumio2). Don’t use the Ethernet cable or a wired connection. Connect to volumio using, via the web interface.

Connect to your wireless network. Volumio doesn’t really tell you if it connected, but the little green info box on the top right should be helpful. Here, since the interface connection changed (you just did that) you’ll have to connect back to your usual WLAN router and check which address was given to volumio. Put that address into your browser and you should be able to see Volumio. Now, turn off the hotspot function by setting “Enable hotspot” to off. That will prevent the hotspot to come up on the next reboot. Now you can reboot volumio, and check if you have connectivity again. A new IP address might have been assign on reboot. Choose to set your IP to static (do actually type the numbers all in, the grayed out numbers in the boxes are just an example and will not be saved!). My solution was to set the WLAN router to give volumio the same IP address on reboot based on the MAC. It’s a complicated way of setting a static address, but I had different network issues at home.

With that you should be able to set up a connection to your NAS. Once you do that, wait for the library to update complete (that may take some time!). If you can’t access your NAS, make sure volumio can ping it first of all.

I couldn’t get any sound from the Amanero USB DAC at first. SSH’d into volumio and tried

aplay /usr/share/sounds/alsa/Front_Center.wav

That did not make a sound. Tried listing all audio cards:

aplay -l

and that showed the amanero USB card as 5,0. Try playing a sound again:

aplay -D plughw:5,0 /usr/share/sounds/alsa/Front_Center.wav

and that worked! Went into /etc/mpd.conf and set

audio_output { type "alsa" name "alsa" device "plughw:5,0" dop "no" }

Rebooted Volumio and music started playing!

Now, I wanted to try the spotify app. I just went and installed it from the web interface, no problems. Again it had no sound. Same thing as before, went into /etc/spopd.conf and changed the following lines to:

[sox] output_type = alsa output_name = plughw:5,0

Now, all is working fine!

I have to say though, it was a bit of a pain in the bum-bum to set all up, and it took me the better part of a day here and there. On the other hand, I’m happy I took the effort and will give it a try for a few days. I haven’t done any critical listening yet, that will be in a couple of days when I have some time for me, but as long as MPD and spotify work, I’m happy.



Thank you for this post! I was having trouble working through the Wifi portion of the setup, but your explanation was great!

I’ve got it running now like a champ.