Music Library empty after reboot - Raspberry Pi + Volumio

When I connect an USB memory stick (128 GB ARCANITE) to my Raspberry Pi (Volumio 2.729 18/03/2020), quickly start the library update and after a while all the music titles are ready to be played.
If I leave the USB memory stick into the plug and I reboot the system, the music library is empty again! Furthermore, if I try to play anything else, for example a WEB Radio, the music doesn’t start.
I’ve to force a library update and then,only after the update has been finished, I can play something by the USB memory or some web radio.

Is there any workaround to solve this issue?

Thanks a lot.

That’s the situation I was having. My first idea of the problem would be that the web radios wouldn’t play, then I’d see the music library (on a local USB drive) was missing. Nothing I tried fixed it until I downloaded a fresh image of the latest Volumio and wrote it to a spare micro SD card and started again from scratch. That install has been working and updating well since then with no re-occurence of the web radio or music library issues. I recommend you get a new image and start again with a fresh install.

Thanks pwstereo, I’ve already tryed with a fresh install, but I’m getting the same result…
I’m wondering if the problem is related to the file system format of the USB drive (NTFS), I’l try with another USB stick in FAT format.

Perhaps it is the file system, I’m not up on what is supported by the Volumio Linux version. Try FAT32 by all means.

Nothing to do : with another USB memory stick with FAT32 file system I have the same issue.
The issue is still unresolved…

Any further idea?

When I was trying to understand what was going wrong, I ruled out the R Pi, and media by installing Moode (similar to Volumio) on a second micro SD card and running that for a week with the same hardware and music collection. It worked perfectly for that entire time, thus I knew it was Volumio that was broken and not the hardware or music files.

I’ve posted a request in the “Bug reports” section… music-library-empty-after-reboot-raspberry-volumio-t14413.html