Music Library disappearing

I have Volumio for a few months now and it has always worked well. Suddenly, I cannot find my USB Music Library anymore.
On a local linux terminal the command
[codepen]ls -l /media/AUDIO[/codepen]
returns a correct file list and all files are accessible.
However, on the remote Windows screen all info seems to be lost. I have done a Settings | Sources | Rebuild but my AUDIO USB stick does not appear anymore. What’s going on?

When that happened to me (along with the web radio stations not working), I fixed it by creating a fresh installation with the latest image.

Thanks PM.
Resetting Factory Settings did the trick. It’s a minor effort but it seems weird this is necessary.

It’s not normally necessary, but every now and again Volumio seems to lose the plot.

I’ve had this issue several times myself. I connect to a home NAS via SMB. It loses the entire library again and again and takes an hour or so to remove the connection, add it, then re-add again. Looks like I hadn’t updated to the latest version (2.773). I’ll see if that makes a difference.

volumio lost library.png

re-indexed again after the update. We’ll see how long this one lasts.


did you find the fix? i have the same problem on my Volumio (via virtual machine). during playing music It loses the entire library and i have to restart the volumio server.

Please don’t cross post.