MP3 file plays in Windows/Linux but not Volumio

I have a few MP3 files that won’t play on Volumio for some reason. When I play them I just hear a squeak for a second or two then it stops. These all play fine on Windows and I tried them on a Linux Mint install just to see if it was a Linux thing.

I downloaded these from youtube using a python script. Wasn’t able to find them else where.

Is there something Volumio is looking for that wasn’t created when the script pulled the audio from youtube?

Here is my log file link

This is the song that has the issue so you can see where I tried playing it Cucamaras - Keep It Cool.mp3. There are 3 others I also downloaded and do the same thing. The squeaks do sound different for each.

Here is the python script I used. Its an example from another site it seemed pretty simple.

andy@linux-mint-vm:~$ cat ./Documents/
from pytube import YouTube
import os

# url input from user
yt = YouTube(
    str(input("Enter the URL of the video you want to download: \n>> ")))

# extract only audio
video = yt.streams.filter(only_audio=True).first()

# check for destination to save file
print("Enter the destination (leave blank for current directory)")
destination = str(input(">> ")) or '.'

# download the file
out_file =

# save the file
base, ext = os.path.splitext(out_file)
new_file = base + '.mp3'
os.rename(out_file, new_file)

# result of success
print(yt.title + " has been successfully downloaded.")

YouTube audio streams are either AAC wrapped in m4a , or Opus wrapped in webm container. Adding “.mp3” will not convert them to MP3 encoding.

If you want to copy from YouTube as MP3 try using the free version of 4K Video Downloader. It alows you to choose the format that you save YouTube files as.

Thank you both that helped I figured out a work around. I read up a bit in the documentation on the streams.filter function and I think it has something to do with the DASH streams splitting audio/video. Not sure on the why but I instead filtered for the progressive stream where they are in one stream and that worked.

So I swapped this line

video = yt.streams.filter(only_audio=True).first()

For this

video = yt.streams.filter(progressive=True).first()