Mounting Windows share


Volumio set up, plugged into router, appearing fine on the network. My music is in a Windows share. I should be able to set this up via SMB, I’m sure, and have done so with e.g. RaspBMC in the past. But no matter what I tell Volumio about the Remote Directory I get a System mount error:
mount: mount point /mnt/NAS/Ben does not exist.

The IP address, Username and Password I’m sure are right so perhaps a problem with the Remote Dir field? No clue, any help on setting up a Windows share in Volumio appreciated.


It seems the /Ben in the update comes from the name I try to give to the mount - no matter what details I put in the rest of the fields, I get that System Mount Error.

Well, this one’s resolved, so I’m putting up my fix in case anyone else has the same problem. If any of what follows is blindingly obvious, well, it wasn’t to me. :confused:

Seems like if the directory Volumio wants to use to mount the shared folder doesn’t exist it won’t create it, it’ll just spit you the error above. So, creating it manually then adding the NAS mount sorted my problem.

Get hold of PuTTY, SSH into Volumio using its IP on your network (user/pass root/volumio), and type the following.

mkdir /mnt/NAS
mkdir /mnt/NAS/SERVER
chmod -R 7777 /mnt/NAS/SERVER

(Where SERVER, in both cases is the name you’re going to give your mount - can be anything at this stage. SERVER is fine :smiley:)

Then go back to the Volumio web interface, add the share, making sure you’re giving it the right IP, Windows credentials, and giving the source name as whatever you put in for SERVER above. Remote dir should be whatever your music folder is shared as on the network. Worked straight off for me and sounds lovely through my AudioQuest Dragonfly. The only reason I’ll be switching back to RaspBMC at some stage is the Yatse Android app for controlling it, for which the voice recognition is stunning.

1 Like

@Unholysmoke. Many many thanks for posting your solution. I too had the mount issue and wasted a whole morning until I came across your method. Worked first time! Now need to figure out how to route to usb (am a total newbie!).

This was a great resource - I have however one successfully mounted drive - can see music files but no music as they play. I’m using a USB via Xmos into a 9026 DAC - raspyfi no problems, airplay with volumio no problems - playing files - no sound.

Also - I did make an error mounting one windows share and now I cannot seem to remove it. When I do this via the web UI it just crashes once I select to delete it. On a reboot - the failed mapping is still there.

Once I get these issues sorted out I will be very happy !!

I also have a dac with usb xmos and usb hard disk, and no sound as your.
The dac make the switch from 44.1 to 24 96khz, i see this by the led, but no sound
When I changed power supply with a little bit more powerful I solved the issue.
Seem xmos sucks a lot from usb.
Anyhow I was using udoo hardware.
Seems only xmos dac have this issue, my other dac no problem.

Inviato dal mio SM-N9005 utilizzando Tapatalk

Glad this was useful. I’ve got my hands on another Pi now, so set it up with a wireless dongle and it’s going to be the kitchen music machine. Great bit of software, talked to my DAC straight away. If I could dream up one extra feature, it’d be voice searching of the database through the web interface.

Tried all the above - I’m on a Windows share that has 3 drives - Media1, Media3, and Media5. Music is on Media3.

Volumio gui NAS looks like this:

Source Name: Scott-PC (this did not exist on Pi, I had to create it following instructions above under /mnt/NAS)

Fileshare: SMB/CIFS

IP Address:

Remote Directory: Media3/Music/mp3/mp3s (pretty sure I have to specify what drive - in this case Media3. Don’t I?)

Username: Scott

Password: xxxxxxxxxx

I get the following error after saving these values in the GUI:

Last system mount error
mount: // is not a valid block device

Any suggestions?

Replying to myself… dumb me. Drive was “Media 3”, not Media3 (missing a space). All is now good!

Awesome! This certainly fixed my issue.

Many thanks indeed!


Dorky response to those having no audio out of Volumio: I had a problem on my initial flight last night. It turns out that since I had an HDMI monitor plugged in, Volumio defaulted to it instead of the analog out (ALSA). sudo amixer cset numid=3 1 made it work. I’m looking forward to hearing it with a more serious audio source.


“Get hold of PuTTY, SSH into Volumio using its IP on your network (user/pass root/volumio), and type the following.”

I am being dim. cant seem to log in to volumio using putty, what am i doing wrong?
user name = user
password = pass

try “root”

and “volumio”

Edit to add: don’t forget to run Putty as admin (right click, run as admin) on Windows.

Thank you!!! I was able to add a working share which then made it so I could remove unmount the non working share. My first time using basic Linux commands via SSH using the Putty terminal program in Windows.

I am hoping to have my first soft shutdown in a few weeks. I have not wanted to create a fresh image for my Rasp Pi2 but maybe that will be my next move.

cheers. stephanie


Thank you so much for your solution. I’ve been looking for this answer for days ! Now I can access my library and enjoy the sound :slight_smile:.

Worked off the bat! Good work!