Mounted NAS but no library


I’m trying to get volumio to work on my raspberry pi 2 with my Synology NAS. After some tinkering with the web interface I managed to successfully mount my NAS (green checkmark). However, there are no files in the library.

I can browse and play specific songs by going through “Media Servers -> Synology -> …” in the web interface.
(I see nothing if I browse "Music Library -> NAS ".)

I’ve seen similar questions on this forum, but none of the solutions have helped me:

I’m very confused since volumio seem to have access and permission to the files (when I browse through them) but my library is empty. Any suggestions on how I can update my library?

  • first make sure your Synology shared folder has “guest” permissions set
  • then in Volumio/ My Music edit the drive settings (green pen icon): open the advanced section and add “vers=1.0” to the options
  • save the drive settings

if this does not work, restart volumio and try to list the library, nothing will show up.
AFollowing that, go to the volumio.local/dev page and send us a log.
Post the link here so we can have a look

Sorry for the (extremely) late response. I got frustrated and tried some other things that didn’t really pan out. I’m now back to volumio, and I hope I can get this to work.

I did what you suggested, and the vers=1.0 did not work, it ended up giving me an error causing the drive to not mount. After this I restarted, and sent a log, which is here:

When I restarted Volumio again, the drive was mounted OK, but I don’t know if this is with the new option vers=1.0, or if it just reset to the settings that worked. Either way, I still see no files in my library. The guest has read/write permissions.

I really appreciate you taking your time to help out. Let me know if there is anything else I can do.

perhaps this helps:

That did help!

That post made me realize the volumio user did not have the correct permissions (I couldn’t browse the NAS using ssh with the volumio user). I didn’t think this would be a problem, since the web interface could browse the NAS effortlessly. Anyhow, as soon as I changed the squash options to “map all to guest”, things work as expected.

(Right now I’m trying to add a specific volumio user, and give it the correct permissions, instead of it using the permissions of “guest”, but I didn’t solve it yet. Anyway, I’m happy I have a solution that works!)

Thank you for your help!