Mount Synology NAS

I have setup a copy of Volumio and cannot for the life of me get it to connect to my Synology NAS.

I have checked the IP address (static) and directory (noting the lowercase) “music” but it simply doesn’t load any of the files for me to browse. I also only see the red “X” in the Library settings. I am connecting to a directory with only 2 flac audio files, just as a test. Both audio files play correctly on the NAS Audio app, on my phone, and also when run using the command line to mplayer. I have also tested the connection to my NAS with a Windows laptop and my iMac. I can also stream music to my Sonos Play speakers.

The settings I have used are

Sourse Name: “NAS Music”
fileshare protocol “SMB/CIFS”
IP Address: “”
Remote directory: “music”
Username: “alex”
Password: “my password”

I left the advanced options as they were, although I did read that there may be an NTLM version setting to use?

Can someone please help me get this setup, or help me find the log files (either in Volumio web GUI or via SSH).

Change “music” to “music/”. That worked for me.

I solved this problem in Volumio 1 by mounting outside of the GUI. Recall that there is a thread on how to do this somewhere in this forum.

Found the instructions: mounting-nas-outside-volumio-t2126.html

Volumio 2 mounts my NAS volume without any problem in the GUI. Doesn’t seem to be quite ready for prime time yet though. The volume control does not work yet for example.

Unfortunately just setting the folder to “music/” didn’t help.

Running a mount via SSHing in did work and allowed me to browse my music. I am wondering if the issue is with the mount options?

Where is the Volumio system log, or where can I see the mount attempts as this may shed more light on the problem?

I was told NFS causes less problems than Samba. So if you have that option, it might be worth a try!

If in NFS, the Mount point might need some extra text. If you are lucky, your NAS can tell you the correct mount point. Otherwise, prefixing ‘/mnt/’, ‘/mnt/HD/’, ‘/mnt/HD/HD_a/’ or ‘/mnt/HD/HD_a2/’ might help.

My two cents. I can’t tell you more.

If you go down the NFS route then the Synology path (on my NAS) is /volume1/YOURFOLDERHERE

You will need to set permissions on the NAS to access your volumio IP address, but no password is needed

Hm, not sure then. I was able to mount my Synology as I specified, all from GUI, no ssh needed. I remember when I had problems I could see it directly in GUI and when I changed to music/ it worked. I assume you are giving correct password as you can mount from ssh.
I did not change anything in advanced options, this is what I have there by default - ro,dir_mode=0777,file_mode=0777
I hope we are both talking about Volumio 1.55, not Volumio 2.

I am on Volumio 1.55.

I think I have found the problem. My password has special characters in it, and a normal command line mount would require it to be passed in quotation marks. I don’t think Volumio does this, hence it cannot authenticate properly. I tried to leave the username & password blank, and specify them in the mount options, but this didn’t work and ended up messing up the web page. Can someone else try connecting with a user that has passwords with symbols / special characters to test?

To fix my problem, I have setup a different (read-only) user on my NAS with a different (but secure) password to access my music.

Thank you everyone for your assistance.

My password has an underscore “_” in it and it works fine for 1.55.01 (Odroid C1). Another thing to check is adding a port number to the URL in case you use HTTPS.

I thik the underscore is allowed, but other characters such as a full stop/period, commas, ^, slashes etc etc should be in quotes. I’m not sure what happens if you password contains quotes itself. It may be possible to use a credentials file.

I have the same problem (using a password with a ^) but this was not always the case. I have a “dev” SD card that mounts my Synology music share without any problem. I tried to use the same account with a fresh SD card from the Volumio 1.55 image but it keeps failing to mount the music share from my Synology NAS, it even refused to remember my cfg which is very annoying having to retype all parameters on every try.

(NB I have to type a space after the ^ sign otherwise it will not appear (also no dot is displayed for this character in the password field))

I copied the player.db (with the working NAS cfg) from the working SD card to the fresh one and now my NAS cfg is listed in sources.php but it is accompanied with a red cross and not mounted. I would like to get information about the error encountered in order to solve this nasty problem but I cannot find it. Also the error field in the cfg row in the database is empty. Who knows where to look for CIFS mount errors?

I tried the following mounting options (N.B. the first is working on my “dev” SD Card) they all fail on my fresh Volumio 1.55 image:

ro,dir_mode=0777,file_mode=0777 ro,nounix.dir_mode=0777,file_mode=0777 ro,noatime,dir_mode=0777,file_mode=0777 ro,nounix,noatime,dir_mode=0777,file_mode=0777 sec=ntlm sec=ntlmv2 sec=ntlmssp nounix,sec=ntlm nounix,sec=ntlmv2 nounix,sec=ntlmssp ro,sec=ntlm ro,sec=ntlmv2 ro,sec=ntlmssp ro,nounix,sec=ntlm ro,nounix,sec=ntlmv2 ro,nounix,sec=ntlmssp noatime,sec=ntlm noatime,sec=ntlmv2 noatime,sec=ntlmssp noatime,nounix,sec=ntlm noatime,nounix,sec=ntlmv2 noatime,nounix,sec=ntlmssp ro,noatime,sec=ntlm ro,noatime,sec=ntlmv2 ro,noatime,sec=ntlmssp ro,noatime,nounix,sec=ntlm ro,noatime,nounix,sec=ntlmv2 ro,noatime,nounix,sec=ntlmssp


I have the same problem with my Synology NAS. Do you use SMB/CFS or NFS in the parameter ?

My problem is that the mount is correct, I can see the files via a ls command in a SSH terminal but in the GUI, I do not see anything in the NAS Folder on the GUI.

In the log file, I have “Permission Denied”…