mount error: solving "unable to find suitable address"

I know what the words mean, but technically what does it mean and how do I fix it please?

This error message shows up in the NAS screen.

I am running a Windows 7 PC. The IP address on the NAS page is

The little computer box I run the music from also shows up on the network. The icon for the little box also has an arrow inside a green circle. The address for it is

I am running volumio 1.5

i have never got volumio to play. The music library is empty too, which is possibly the maximmum 10,000 files limitation discovered back in 2014.

Please, if you can help, your volunteering and kindness is appreciated.

Hello, is there anybody there?

I am seeking help on this problem. Is there an answer, please?

If there is not enough information on the way I have asked the question, can someone please say what other information is needed please, so that a solution can be provided please?

thanking you

well, I’ve been reading your post in some other thread about complaining that you dont get help.

Actually your description is quite cryptical, i.e. nobody knows what you were doing when getting that error msg.

Also, instead of listing the configuration of devices and how they are connected you use your own descriptions that may have a meaning for you but not for plain stupid ppl like me (whats ‘your NAS screen’? your ‘NAS page’? what device has that IP? whats the ‘little box you run the music from’?)

It also seems to to me that you also quoted that error msg not exactly, did you google it?

The 2nd part error msg 'Unable to find suitable address can be found though and a quick glance through results would make me look at your fstab file for potential errors there.

Am no unix freak though, so just my 2c - hopefully you will be able to solve your problems

GL :slight_smile:

Hi blueblueblue - thank you, I can answer these questions now I know what you are looking for. I was not being cryptical, I simply don’;t know. I am here because I want to play music not do things with computer code and volumio is a plug and play option so it tells me.

whats ‘your NAS screen’? your ‘NAS page’?

This is the page in volumio on my browser that lists DB sources and NAS mounts volumio.local/sources.php

The message appears under “NAS mounts”

Here is copy and paste of the text. The error message is in bold

NAS mounts
Edit network mount ( )

Last system mount error
Unable to find suitable address.

Source name

fstab file? The wikipedia entry scares me. This is not about music.

The setup is this. The little box is a cubox computer.
Windows 7 PC >>> to cubox with volumio flashed to it >>>> to DAC

What i was doing was attempting to update the library before playing Volumio for the second time. The library did not load even though everything worked fine on the first time, when there were a dozen files in the library. I was attempting to load many thousands of files.

thank you

there is something I don’t understand :
you wrote :

Why both got the same IP?
What is your nas ?
You are talking about Windows 7. If you use it to access Volumio, you can try to enter http://volumio.local if you don’t know exactly the ip address.
You wrote :

The first time, were your files on the same nas ? Same folder ?
How do you try to connect your nas ? using SMB or NFS ?

let’s try a more structured approach so that we understand what your plans are:

  • where is the music, that you are trying to index and eventually play, on a NAS, on the PC or somewhere else?
  • when PC or NAS, what IP address does that machine have?
  • when PC or NAS, did you define a share on the drive/folder that holds the music? What is the name?
  • when somewhere else, is it a disk connected to the machine where Volumio is connected too?

sorry, balbuze was quicker while I was typing