Mount a Synology Volume via NFS: Cannot assign requested address

Volumio Information

Volumio Version: 2.873 (fresh install)
Hardware: Raspberry Pi 3
DAC: HiFiBerry Digi

As my NAS HDDs an my Volumio SD-Card are failing, I decided to reinstall the latest Volumio image to a new SD-Card.
After the installation, I tried to connect to my new Synology NAS Mount via NFS. I transferred all files to the new NAS and set all permissions exactly like I did in my old Synology NAS but this time I can’t connect the Volumio to my network mount.

I always get the message “mount.nfs: Cannot assign requested address”
I also checked the Good to Know Article about Synology NFS Mounting without any success.

Interesting is, that when I try to mount via IP-Address, I receive “access denied”…

Can anyone give me a hint, whats going wrong?
Thank you a lot in advance.

Same situation here. It was always working, but with the latest update I’m no longer able to connect to my Sysnology NAS. Neither nfs nor cifs is working!

Solved for cifs. It needs SMB3 enabled in the Synology DSM. So I got it mounted via cifs and user credentials. Can’t say about nfs.

It’s very difficult to make any suggestions when we don’t know what your current settings are. For starters, can your RPi see any NFS mounts on the NAS? From the cli of your RPi type:

sudo showmount -e 192.168.x.y

where the Ip address is that of your NAS.

1 Like

I just don’t get it.
I just tried again to mount, and this time it worked!!!
I just repeated the mount command like earlier from the history.

Thank you for the hint with showmount.
I tried the command and it listed all the mounts including the music mount.
Maybe this was the reason, why it worked now.

Hello cetheus,
I also have some issues with Nas nfs mount. Now I use cifs. The nfs does not work, it used to work… Could you please give me exact the configuration from volumio.l and from synology, print screen it will be great.

Hi Lintbf,

I used the Good-To-Know I linked in my initial post.
If this does not work, you could try the following:
Log into your Volumio Instance via ssh.
First run the showmount command, chsims1 mentioned and then
try to mount your NFS share with “sudo mount -t nfs -o ro,soft,noauto <NAS>:/volume1/<path> /mnt/NAS/<Alias>/
Maybe it can work, when you begin your path with a / in the web-frontend.

These solved my problem.

I just delete the cifs share and add the nfs share like I did it in the past and it work. I can not believe it. I am on buster beta version 3.054.

1 Like