more than one

Dear all,
after having mounted successfully and permanently the hard drives attached to my airport extreme I tried to set up a second volumio in the same network. Unfortunately I did not manage to use them both. I reserved fixed IP adresses and both PIs are working fine it is just not possible to access them both at the same time.

Anyone any ideas?



this is not clear when you say :

Just to make sure do you confirm that you are trying to access them via their IP (volumio.local) ?

As their is no reason why you could not access both of them at the same time on the same network.


Hi and thanks for the reply. I tried to access them via their fixed IPs, but it is just possible to access the one which was connected first to the network. When I am checking the clients connected to the router I can also only see one of them.

Problem appears to be network related. If you try them one at a time (i.e. one switched off and the other on) do they work? Have you got a duplicate IP address set with something else?

Yes, both are working fine separately. When they are both switched off no matter which one I boot first, the first one connects to the network, the second one doesn’t. It is a network issue. They are both fitted with a wifi dongle and I reserved two different IPs for their MAC addresses. I thought it might be a problem with the hostname. Both PIs will connect as “Volumio”. Is there a possibility to change this?

I also think it’s a hostname problem: some routers just don’t accept duplicated hostname. To change this

nano /etc/hostname

And change to whatever you want, then edit

nano /etc/hosts

accordingly (put the hostname you wrote before instead of volumio).

Then reboot. If that doesn’t work, try to disable Airplay on one of the two, and report it please