Mixer Type info


I have not exactly figured out the mixer control type function in “playback options” page. Exactly software, hardware and none how they function and how they impact on the playback quality?


None : no volume control in volumio. You have to use your preamp or amp to do this.
Hardware : you use hardware capabilities of your dac IF exists to set volume. The best way to control volume.
Software : if your DAC does not support hardware mixer, use a software mixer provided by alsa. Purist would say it is not hi-fi because you reduce quality… but in practice it’s hard to hear the difference on most system… and really convenient…

Hi balbuze and thanks for your explanation,

my DAC, is connected in USB, with the mixer type set to “none”, when I start playing I get an error (error to open output stream). If I set the mixer type on “hardware”, everything works. What could be the reason?

“None” should works in any case… Try the following :

  • choose audio jack as output and save
  • save hardware mixer setting
  • choose your DAC and save
  • choose mixer “none” and save
    It’s a bit weird but it could help… :wink:

Ok I’ll try, thanks :slight_smile:

In any case, even with the “hardware” setting, it means that volumio leaves intact the output stream. Right?

I tried to follow the steps balbuze, but the problem remains: with the mixer type set to none, the play does not start and I receive the error “Error to open output stream”.
It’s very weird!

Hi! have the same issue with my Udoo quad and Volumio 2.118.
Out of the box mixer type is set to Hardware; when I change it to none, the play does not start and I receive the error “Error to open output stream”.

Any clue what the issue is?

Same issue here.
Pi B, HiFiBerry DAC. Mixer type ‘None’.
‘Error to output audio stream’.
Volumio then crashes and restarts if I try to browse for music.
I can select a ‘wrong’ DAC card and it plays ok!
Not a happy bunny…
Any suggestions, please?

Waiting for a proper fix (btw, is anybody looking at it?) I tried to manually change mpd.conf, altering mixer_type from “hardware” to “none” as below

audio_output {
type “alsa”
name “alsa”
device “hw:2,0”
dop “yes”
mixer_device “hw:2”
mixer_control “M2Tech Clock Selector”
mixer_type “none”

I restarted my Udoo and the setting is retained. Not sure if this is enough to get the mixer fully disabled.

Fixed see github.com/volumio/Volumio2/com … 6bf3499e26

thank you for reporting. Anyway, the proper place to report issues and bugs is github.com/volumio/Volumio2/issues
where we can track them

Thanks, michelangelo.
Do I need to make a fresh install of Volumio to apply the fix, or will it update automatically when next I start up my Pi?
Or do I need to SSH into the Pi and alter some code as per your link to: https://github.com/volumio/Volumio2/commit/0ee5830d72efb2a019e23de171f1306bf3499e26, replacing the existing line 620 (indicated in red) in app/plugins/audio_interface/alsa_controller/index.js with the new line 620 (indicated in green)?
Or something else?
Many thanks in advance.