Missing files on NAS drive?

I have Volumio running on a Raspberry Pi 3. Originally I used a local USB drive to store my music, and everything worked fine. I decided to set up an NAS drive on another RPi3, using Open Media Vault. This worked ok, but I could only see files by artists whose names started with A - J. I tried rebooting everything, and re-setting up the library on Volumio, and now I can only see files by artists whose names start with A - G. I can access all of my music files on the NAS from my desktop. I set up another music player using RuneAudio & another Rpi3, and that will see all my music files on the NAS also.

So any suggestions on why the Volumio player won’t see all the files? The files are a mix of FLAC, AAC, MP3, and Apple Lossless. The missing files are not of any one type. I did search the files here but didn’t see this specific issue, if I missed it just point me.


If you have access to the command line (by ssh or by direct connection to the RPi), can you check the directory ‘/mnt/NAS/yourNASname’ and see if all of your music files are shown? If not, then you should double check the permissions that you have set up on your NAS.


By SSH they are all there.

As they are all in the one directory, they should have the same permissions I think? I’m not sure how to check that.

Check that the missing files are indeed in the mpd database:

mpc listall

If they are, chose one which doesn’t show up in the UI and add to playlist & try to play (clear current playlist from UI first):

mpc add 'NAS/TheSutherlands/Sam Music 2/Pendulum - Violet Hill (Coldplay Cover).mp3' mpc play

P.S. What version of Volumio are you using?

It is version 2.246.

I did not check the other you mentioned, as I did a rescan which took several hours, and I went to be before it finished. It picked up a lot more tracks than before, not sure yet if it got all of them or not. I think maybe the first time the scan did not complete for some reason? Hopefully I can spend some more time this weekend & dig deeper.

I have the same problem. Files on a remote file system (SMB) are not visible in the GUI. I have 2792 files in the mpd database. I have identified 21 tracks from a single album that are missing from the GUI. There may be more, I just haven’t come across any others yet.

I did an ‘mpc listall’ and the files are listed. I was able to queue and play the files using mpc as described above.

Interestingly the album appears in the GUI, but it is empty. I can navigate directly to the files on the NAS with the GUI and play them. Is there an equivalent to the ‘mpc listall’ command for the GUI’s database so I can compare it to the mpd database?

BTW: platform is RPi3 running 2.246 with Allo DigiOne.

I have upgraded to 2.296 and the problem remains. Album appears in the GUI but has no tracks. The tracks appear in both the MPD database and on the NAS. Tracks are playable directly from the NAS. I have performed a Rescan with no change in missing tracks.

I anyone looking into this?

Hello, it is quite old post, but does not seems to be resolved. I have the same problem. I wonder if anyone got solution?

I ran into a similar problem and the issue turned out to be permissions. I was able to give them 755 permissions and the issue went away. I was able to scan all music on my NAS and it was all visible in Volumio.