Minix mini PCs

Can anyone tell me if Volumio can be run on Minix computers that have Atom processors?

I don’t know much about processor types, but all Atoms are x86 right? and therefore compatible with Volumio?

A friend of mine has a rarely used Z64-Android model which has a 64 bit Atom Z3735F CPU that he’s will sell to me on the cheap. It looks like an ideal device for Volumio but am I wasting my time on this?

Does the fact that it’s designed for Android make it incompatible? There are versions designed for Windows out there but there quite significantly more expensive.


An update on this in case anyone finds this thread.

It sort of works, with the following issues:

• The on board wifi chip isn’t supported (yet), so I’m using a USB dongle.

• The built in hard drive isn’t recognised from within the Volumio terminal which means I haven’t been able to install to the SSD.

• I also can’t get it to boot from the SD card (unrecognised in the BIOS).

All this means that I have to have the USB DAC, wifi dongle and the Volumio boot USB connected to the two USB ports (so obviously a hub is needed, which probably isn’t ideal).

The first attempt at scanning my NAS failed when the computer crashed halfway through the process. I’m trying a second attempt now.

It seems likely that this is will ultimately be a no-go but I’m not sure how much of this is down to the use of the USB hub.

please google for installing linux on a minix Z64, it seems you have to adapt 2 parameters in your BIOS to stop the unit freezing/ crashing.
e.g. the follwowing link, look at section “BIOS Settings”

OK, we have an experimental x86 image based on kernel 4.12.8, it works on my Intel NUC and Asus notebook, so should be OK.
eMMC is enabled and also the internal rtl8723bs wifi, I’m curious if this will work on your minix Z64 (please fix your BIOS too).

Download it from here

Excellent work, thanks.

I’m out for the rest of the day but will give this a shot tomorrow night if I have time after work.

For what it’s worth, I’ve now listened to a couple of albums of 44.1kHz FLACs on the Minix using a USB dongle and the performance is passable. Skipping in the opening 10 seconds of tracks happens maybe 70% of the time but I haven’t played with the buffer settings yet.

ok, but let’s tackle one problem at the time. First get the basics working, wifi, emmc, sd etc.
The rest should be easier once we know how the device behaves.
Btw. the work is not just for the minix, there seem to be a series of new x86 devices with similar configurations.
So my interest is to get it running as a general x86 build, hoping you can help testing with a Minix Z64.

Wish I had one of those here :wink:

I finally got around to testing this tonight.

I changed the BIOS settings as mentioned in that blog post but unfortunately it looks like the wifi isn’t working (no networks found, manual connection failed).

It’s a similar situation again where the “wireless networking” switch goes back to “off” when I change pages.

Oddly, under “network status” it does say the hotspot is active and online with an IP, but no hot spot is visible on my network.

Any suggestions? I’m willing to put some time and effort into this to get it up and running.

Having used the terminal to list the network devices with ‘ip link show’, i do now see:

2: wlan0 <BROADCAST, MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000 link/ether 40:e2:.....

I tried to enable it with:

sudo ifconfig wlan0 up

but got this error: SIOCSIFFLAGS: operation not permitted

could you produce a log please.
You will have to connect the minix via eth0 (otherwise it makes no sense) and use the UI on another system.
Go to the dev page and enter a description with your nick and “minix issues” (so I know it is yours).
dev page: /dev

Apologies for taking so long to get to this (the last week or two have been very busy).

The ethernet on this device doesn’t appear to work (at least when Volumio is running). I’ve attached it to my router with an ethernet cable, but the corresponding LED on the router turns red indicating that a connection isn’t possible. I’ve tried with a few different cables to be sure.

Would producing a log while connected via USB wifi be worthwhile? Or would that defeat the purpose?

EDIT: Actually I was wrong. It seems that it’s attempting to boot from the Windows install on the internal drive again - I must be doing something wrong. I’ll report back later.

I was being dumb - trying to boot off the wrong USB stick.

Log submitted with the title “minix issues - james_b”

Anything of note in the log, gkkpch?

sorry for not doing this full-time, I take days off sometimes :mrgreen:
I won’t be able to look at it because of a house full of visitors.
Probably Monday…

Sorry, I looked for your log file, it obviously got cleaned up before I could secure it…
Could you do it again please?