Micro SD card errors trying to run Volumio 3 on a Pi 3B

Hi everyone,

I’ve been using the Volumio 3 x86 build on a old laptop for a few weeks and it’s been great - but it’s a borrowed laptop so I need a longer-term solution. Enter the Raspberry Pi.

So I’ve bought a new Raspberry Pi 3B (the Pi 4 doesn’t work well with my Audiolab M-DAC, another story…) and it appears to start up fine with the flashed Volumio 3 image on a new 16GB micro SD card flashed using BalenaEtcher. During the start-up process the display shows “resizing the filesystem on dev/mmcblk0p3 to 12830372 (1k) blocks.” Then after a couple of minutes I can log into Volumio and use the web interface. All OK so far.

I then shut Volumio down, wait a minute and restart the Pi, after which it never boots from the memory card. I get “mount: mounting /dev/mmcblk0p2 on /mnt/imgpart failed: Input/output error” and various other errors indicating that the partition seems unreadable. The only solution is to reflash the memory card, but the error always happens again after the first restart of Volumio.

I am running the Pi off a third party power supply (5V 3A) with a good quality micro USB cable and no indications of under voltage, although I guess I can’t be 100% certain of the reliability of this.

I tried a different (32GB) micro SD card and it also fails, but with a different error.

Here’s a link to some screen shots: https://photos.app.goo.gl/4g8FqSd8Mw9ZuS2v9

Anyone seen this or got any suggestions? The failure might be at the hardware level, I guess, but I thought I’d ask before getting a new power supply.

Thanks :slight_smile:


Can you try to reflash the SD with Win32DiskImager or Raspberry Pi Imager and try again, If you still get errors:

  • repeat above step
  • Extract and insert the SD to your computer
  • open /boot/cmdline.txt and add sdhci.debug_quirks2=4 at the end
  • Put the SD in the rPi and run the setup
  • Reboot and see what happens.

If these steps work, keep in mind that on every OTA, the cmdline.txt file gets restored, so you need to add this again.
I had the same issue with one of my SD cards. Adding this line solved mine.


Part 1.5: 3.3V power still interrupted (Source)

Because of a another issue, the 3.3V pin still resets when a HAT is connected to the Raspberry Pi 4. The workaround described in the linked GitHub issue is a kernel flag.

The option sdhci.debug_quirks2=4 must be appended to the end of the line in /boot/cmdline.txt:


The sdhci.debug_quirks2=4 disables ‘1.8V’ mode for SD card, so that makes UHS SD cards to be used at lower speeds, but this config also prevents power being cut off on the GPIO’s 3.3V supply, avoiding the reboot issue.

@Wheaten Tried your suggestions but unfortunately still get exactly the same. For some reason Raspberry Pi Imager didn’t seem to work when I tried to flash the micro SD card, but Win32DiskImager did. The micro SD card is a new SanDisk Ultra Class 10 card so I think it should be OK (the other card I tried was a Samsung Evo 32GB Class 10 card, also gave errors).

Anyone got any further suggestions, or should I be looking at the power supply next?


Perhaps Rufus? it has helped others with PI Imager issues, worth a try with the Sandisk.

@gkkpch Just tried reflashing with Rufus and got exactly the same result. It appears that the partitions dev/mmcblk0p2 and dev/mmcblk0p3 start off OK in their initialised state after flashing the card (the same whatever tool is used to perform the flash operation) but as soon as Volumio has started up using the card those two partitions become inaccessible for some reason. As far as I can see the boot partition is fine (you can examine it as a Windows drive), but I’m not sure if it’s possible to inspect the other two partitions.

Although I don’t see a low voltage warning (the same when I try to flash NOOBS, which runs fine), is it possible that after the first startup Volumio causes the Pi to gulp current momentarily and misread or corrupt those partitions on the card?

Any further suggestions welcome :slight_smile:


Just tried again, this time with an official Raspberry Pi power supply - no change, Volumio starts up once and appears to work then I still get i/o errors as soon as I restart Volumio. I downloaded Volumio again just in case. Am I just unlucky with my two micro SD cards or should I be trying something else?

Tricky one…

I would say one of the two is fauly: SD Card or PI…

Hey. I’m having exactly the same issue as the OP. Any update on cause/solutions?