Message NOSPC no space left on device, mkdir '/data/temp'

Hi everyone, every now and then I try to make friends with volumio but unfortunately we often argue.

Today I installed the System Version: 3.695, after creating the microSD (32GB) I inserted it into the rasp4 and it took a really long time to boot (it maximized the free space according to it).

Once the system loaded I tried to install the “Touch Display” plugin and to my surprise I received this message:
Error installing plugin Error: Error creating folder: Error: ENOSPC: no space left on device, mkdir ‘/data/temp’

I can’t continue anymore, does anyone have any suggestions?

Thank you

Sounds like something went wrong during resizing. the free space is not reproted correctly, leving the OS to think it’s full.
Best thing to do reflashing the SD and start over.

I wrote a new micro SD (32 Gb) with “OK” validation after writing. After about half an hour of “space optimization”, installing the touch display plugin, same error and another argument with volumio.
Perhaps all that remains is to find a previous version of the volumio that does not optimize anything (this operation could have been documented before and proposed at the user’s choice given the time it takes).
Thanks for the reply and it’s a pleasure to “see you again” here.

I do not know where your “space optimation” comes from, the only thing that happens during a boot process is re-sizing the data partition to its maximum size (message “Expanding internal storage space to maximum, this can take a minute”).
With a 32Gb SD card, re-sizing should take a while, but not half an hour.
What kind of card is it? Brand, Class?

yes, time passes with the resizing of the partition, the micro SD cards I have are Class 10 type U1 unknown brand “eny”.
Even with the previous version of Volumio there is scaling and here too after startup the error appears when installing the touch display plugin
Could it be due to the Raspberry 4 which only has 2 GB of RAM?
Is there a way to download the plugin and do the manual installation?
Thank you

First check a few things:

  • Is your power supply adequate to power both the rPi and Screen?
  • You burned the image using “Raspberry Pi Imager”?
  • Have you booted the system without any screen attached?


  • the power supply is the original one for the Raspberry 4 and the monitor is a portable external unit powered independently.
  • I wrote the image with “balenaEtcher” just downloaded and installed with write validation
  • I started the Raspberry with the newly created SD with external monitor on the miniHDMI 1 port and external Cambridge Dacmagic100 USB DAC (and the audio works regularly)

I’ll try as soon as I have time:

  • to buy a new “emblazoned” SD card
  • create an image from an SD that is inside a Rasp 3B by restoring it on one of the SDs tested today
    For now I have no other ideas…
    Thaks Hi

Burn your image with “Raspberry Pi Imager” as Balena generates all kind of errors.

It was the SD completely fake in size (I’ll throw away a pack of 5 SDs)
With a well-known brand (Kingst…), already from the resizing which took no more than 5 minutes, everything worked perfectly.
Thanks for the support, I will share more experiences to help the large volumio community

Did your order these (fakes) from Ali?

@paolo.p Already thought so, why I asked for the SD details.
We had and will have more reports of issues with re-sizing due to cheap Chinese fakes.
Aliexpress is not all bad, but you run a bigger chance getting fakes.
But stay away from Temu, loads of rubbish sold off with huge marketing efforts (my opinion).

Yes I got the SD from Ali, I thought it was better than Temu but Amaz is still better even if more expensive.

@paolo.p It’s possible that it’s the same problem as here: No space left on device on fresh volumio 3 (Raspi-4) 64GB SD card - #39 by MrPing