Merus Pi Hat not recognized

Volumio Version:2.882
DAC: Infineon-KIT_40W_AMP_HAT_ZW
Rasberry Pi 3B+

Steps to Reproduce

  1. attempt to play a flac file results in error message - essentially no alsa device HW 2,0

Additional Information

Volumio works fine with HDMI

  • Compatible with Raspberry Pi Zero and Raspberry Pi Zero Wireless

and you want to use it on rpi 3b?

Sorry, i’ve been troubleshooting the hat driver using infineon’s git build instructions on pi zero, pi 3B+ and p i4. Which all fail with the same issue. The HAT was on a pi 3B+ . I decided to try another image - yours - and got precisely the same dmesg errors reported on your build. I will move the HAT to a zero and expect volumio will work there. Again, sorry - I didn’t read the fine print for volumio hardware. Basically the problem I am chasing is a probe failure on the codec which prevents instantiation of the merus driver.

i hope that it’s still included otherwise it’s gonna be dufficult to get it running
but running a hat that old on newer hardware is most of the time or not possible or a headache
to deal with… but maybe some one knows your hat and if he got it running that’s the question
but they always want to look at logs of volumio if it’s saying some errors and try to fix but
without a board it’s difficult knowing what’s going on… and test.

and did you the i2c set right?
and i would say if you find no solution in the 2 version try the 3.xx maybe that solves it…

1 Like

I did not set i2c - not sure how to do it on volumio image. I just took the gui way with raspi-config using my images. While troubleshooting my builds, enabling i2c and/or gpio did not seem to have any effect.

i think you have to wait for some one who knows how your hat must be set
if it’s possible i don’t know…

Hmm, you shouldn’t need to build any drivers, as this DAC is supported out of the box with Volumio.

Can you start from a fresh image, select the “merus-amp” from the Volumio DAC selection and post some logs?

Will do this evening.

Didn’t work. aplay -L only showed the builtin Pi audio.

Looks like it’s unable to detect the board - does it work properly with vanilla Raspbian?

kernel: ma120x0p 1-0020: ASoC: failed to probe component -121
kernel: snd-rpi-simple soc:sound: ASoC: failed to instantiate card -121
kernel: snd-rpi-simple soc:sound: Failed to register card -121
kernel: snd-rpi-simple: probe of soc:sound failed with error -121

You should be able to use the same device tree overlay…

dtoverlay merus-amp

After a lot of testing/blind alleys tried the sd card in another pi with another merus HAT. That worked fine. Further troubleshooting led to the inescapable conclusion that I got a DOA merus HAT. I do want to thank those who gave good, valid steps to take.