Major Boot issues with pi 3b+ and Allo boss v1.2 hat

I have a 3b+ Pi 32gb/SanDisk with a Allo Boss v1.2 hat.
I use the latest img of Volumio, burned with Etcher.
Power connection is done with two different adapters. One goes to the hat (5v 2.5A) the other is an original Pi adapter.

I have huge issues nearly anytime when booting the pi. Once in a million it boots correct, works really well and sounds amazing.

But that is only the case when i burn the image from scratch (loosing all prefs), or after that in 1 from 50 bootings are running succefull.

I recieve severall error versions.

Mostly input/output not found error right from the start but also blackscreen (nothing happens) or i get the login screen with the ASCII Volumio graphic after login, but no start melody and the service cannot be found via the app.

Tomorrow (i hope) i get an Allo Nirvana SMPS, which is my last hope so far. Is there anything else you guys could tell me about what am I missing, except from power connection?

I stuck…


Did you remove the power jumper to separate the HAT power supply from the main Pi power supply?

Hey, thank you for the quick reply. :slight_smile:

Sure, it was (and still is) removed.
Before that, i tried powering just over the hat, with the jumper in place. Same result, thats why i tried double powering the whole system.

Is the SD card directly on the PI or do you use an extension slot? I had similar issues with slots, especially with fast SD cards

Its directly in the Pi. No other external source is connected. At the moment i only (would like) to use Spotify in HiRes.
The Allo Nirvana is arrived today, but that didn‘t solved it. :confused:

I will try another sd-card, maybe that one is too fast (thats possible?)

I wasn‘t aware of it, but changing the SD-card seems to work. Now I use a simple card, the one before was a Kingmax 16GB Class 10 TF.
Now after a first reboot, which was always the critical step, it works so far!
I hope it stays that way. :smiley: