Lost Qobuz and other functionality on 3 MyVolumio Units

I have 3 MyVolumio players on my network. They have been relatively trouble-free for some time.

All 3 are Raspberry Pi based. (Zero W, Zero 2 W, Pi 4)

Qobuz quit working and does not show up now on any of them. It is not on the main menu (“browse”’ on classic UI I use) or in the “sources” area.

I can choose a song from Qobuz via a saved playlist and see it as “undefined” on the queue. It won’t play (Pi 4), or…
it shows up on queue but I get the " failed open Alsa" error.

I have tried

  1. logging out and back in MyVolumio
  2. switching out of the i2s dac settings, restarting, adding it back and restarting again.
    …which have worked to solve similar issues (previously limited to 1 unit) in the past, but they don’t work now.

Help, please.

I want to add that,
2 units will play local files but the 3rd will not, even after the steps I noted above, I get “failed to open alsa device “volumio” no such file or directory” error.

I may be getting closer. I tried to access plugins and got the message that I need to login MyVolumio. Of course, I was already logged in but I logged out then back in again, yet still continue to get the error.

And I am accessing via IP address in Chrome as I do so.

check if in myvolumio there is a play button for the failing Volumio installation. If there is press it. Had the same problem and pressing the play button solved it.

Thanks. There was not.

I ended up burning a new copy of Volumio on a fresh SD card.

I used it for the unit that was not working at all. After installing it, Qobuz appeared again for all the units on the network.

It seems odd to me but apparently that one device ended up getting a corrupted OS which somehow affected the account and/or other devices on the network.

Make sense?

I had a similar problem with one Volumio device not showing the “Play” button on MyVolumio page. It works again after a Volumio factory reset on that device and new initial setup.