Lost connection after configuration

Strangest thing… After the hassle with my R-Pi Zero, I just got a brand-new R-Pi 3. Installed Volumio on a fresh SD, plug it in, hotspot starts, connect to it and configure everything. It restarts the Wifi and then… nothing. All signals lost.

In my router I can see the Pi is connected to the wifi, but it’s not accessible through the IP address. I manually enabled ssh, yet the host cannot be found. Green LED blinks every 10-20 seconds, apart from that there is no sign of life on the Pi. Even ping is unresponsive.

I tried rebooting, another SD card, freshly downloaded Volumio image, all no success. I use a 2-year old Win 7 laptop with built-in card reader and Win32 Disk Imager to write the sd cards. I would be surprised if it’s a sd card thing, since it boots normally the first time. Cards are Sandisk Ultra 16 gb. Power supply is an R-Pi 5.2V/2A.
I also double-checked in the router that all configurations to the Pi Zero running on this IP address are removed. Even tried a different IP, same story.

Any ideas on this?

Could you connect it to a monitor and check the results of ‘ifconfig’, and ‘sudo iwconfig’? You could also have a look at the system log (sudo journalctl -b) and see if there is anything showing up there.

I might also be tempted to try a USB wifi dongle, if there was one available.

I don’t have a monitor available for that unfortunately, I’m forced to run all the Pi’s headless. I will check the system logs when I get home though.

Why a wifi dongle? I still have one from my first R-Pi to try, but wifi always worked well even with the little Pi Zero W. It’s only a few unobstructed meters away from the wireless router.

Is your wifi channel on #12 or #13 (maybe this changed with router’s dynamic channel allocation)?
If so, you probably need to set region code in CRDA: on your Pi please check this.

Wifi channel is set to 6 on the router for 2.4 GHz and auto for 5 GHz.
I also did a fresh install again (v 2.348) with another SD reader, same behaviour.

Where can I find the logs on the SD card, without being to able to SSH into the Pi?

So it has to do with the Wifi. When I create a hotspot with my phone it works. I tried Volumio 2.232 since that worked on my R-Pi Zero W, but it also looses connection after configuration. I checked this topic, but the last answers are some time ago.
I will try my dongle tomorrow. If I can provide any logs, let me know how to extract them and I’ll send them.

You can’t get logs on SD, I’m afraid.

Did you let first boot alone for about 6-8mn before doing anything on it?
First boot takes long and needs to settle a while, as mentioned in the Quickstart guide.

Though I would be surprised your hit by this here, Pi3 wireless firmware has some know issue (independent from Volumio), that is currently been resolved as per this (beta test, not released yet).
Is your Pi3 wifi working fine if using other distribution (like Raspbian)?
To help debug (and push logs for review) can you eventually use an ethernet cable or wifi dongle?

Okay, I might have to do that :blush: Never encountered this with my Pi Zero W, so maybe I’m a bit too eager.

I will burn a Raspbian image on my second SD card and test it tonight. I can also hook the Volumio installation to ethernet to get the logs, keep you updated. Thanks for the help!

just remember for ssh with volumio goto volumio.local/dev and and press the button “enable ssh”

but if you cant reach your RPI at all it will of course be difficult.

Try this, it worked out for me after having the issue you describe: install on your RPI different distro, I took runeaudio. It stored and connected with Router new. After that reflash new the volumio, go thru config, this time it remained connected after reboot. Seems the Router wifi config mixes the ID up, i dunno exactly what happened.

Make sure the Option “pair allways with this IP” or similar on your Router config is marked.

I connect the Pi to ethernet and pulled all the information that you asked.
The full log can be found here: logs.volumio.org/volumio/2VCcyf7.html
Strange enough the log mentions entries of November 17th, before skipping to the current date. This image was written last week…

My to-do for tonight:

  1. try Wifi with Raspbian.
  2. fresh Volumio image, let it boot for 15 minutes the first time.
  3. if 1 and 2 don’t work, try this: raspberrypi.org/forums/view … p?t=203508
  4. flip the record occasionally while vinyl is my only source of music left now :laughing: :laughing:

ifconfig output:

volumio@volumio:~$ ifconfig
eth0      Link encap:Ethernet  HWaddr b8:27:eb:9f:c4:46  
          inet addr:  Bcast:  Mask:
          RX packets:933 errors:0 dropped:1 overruns:0 frame:0
          TX packets:1653 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:83071 (81.1 KiB)  TX bytes:1976585 (1.8 MiB)

lo        Link encap:Local Loopback  
          inet addr:  Mask:
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:1784 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1784 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1 
          RX bytes:170834 (166.8 KiB)  TX bytes:170834 (166.8 KiB)

wlan0     Link encap:Ethernet  HWaddr b8:27:eb:ca:91:13  
          inet addr:  Bcast:  Mask:
          RX packets:4 errors:0 dropped:0 overruns:0 frame:0
          TX packets:38 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:924 (924.0 B)  TX bytes:8370 (8.1 KiB)

sudo iwconfig output:

[code]volumio@volumio:~$ sudo iwconfig
eth0 no wireless extensions.

lo no wireless extensions.

wlan0 IEEE 802.11 ESSID:“BayerischerHimmel”
Mode:Managed Frequency:2.437 GHz Access Point: 1C:67:58:8A:5E:20
Bit Rate=72.2 Mb/s Tx-Power=31 dBm
Retry short limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality=68/70 Signal level=-42 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

… and the results:

  1. Raspbian Stretch lite (v. 4.9, 29-11-2017) works fine right away. After configuring the Wifi over ssh, it connects to the wifi and is accessible via ssh.
  2. Fresh Volumio and waiting 30 minutes for the first boot to finish did not resolve it - same issue.
  3. Firmware update of the wifi did not resolve the issue either. It still cannot connect to the wifi.

Strange enough, when ethernet is connected I can access the Pi shows up twice in my router. I can connect to both IP addressess too.

Hopefully you can discover something in the logs, because I have no clue anymore.

Posted log says: VOLUMIO_VERSION=“2.323”
Can you please stick to latest stable 2.348 for now?

looking at your ifconfg log:wlan0 Link encap:Ethernet HWaddr b8:27:eb:ca:91:13 inet addr: Bcast: Mask: your device does seem connected over wlan.
This is confirmed as “when ethernet is connected I can access the Pi shows up twice in my router. I can connect to both IP addressess too.”

So, are you saying wifi only works when ethernet is plugged-in simultaneously?
Is your wifi password containing “complex” characters (like quotes)? Can you try with a simpler password?

Right… I tried a v 2.323 as well, forgot that I didn’t make a new image anymore.
Here is the log of v 2.348 that I burned last yesterday: logs.volumio.org/volumio/3mRVcs4.html

It sort of does. My router lists it as connected, but I cannot access it. No SSH, no webinterface, not even ping.

That is exactly what seems to be going on.

Reminds me of this older thread which did not go through, mixing various stuff.

While you have the 2 interfaces ON, can you please use Volumio UI to turn OFF Volumio’s Hotpsot option in Network settings?
Does it fixes the issue and allow wifi to connect to your home router alone?

Turned it off, rebooted without ethernet attached. Again the router indicates it is connected, but the host is unreachable when I try to ping it.

The behaviour is similar to what is described in the topic you linked. When I connect to ethernet, the Pi is accessible by it’s wifi IP. It stops as soon as the ethernet is disconnected. All without reboots. Simply bad luck with the Pi?

Ok, so you can NOT access UI on (assuming this is still your wifi IP), but can on ?
(please make sure which IP corresponds to which interface. You may want to temporarily have your router to assign a fixed IP according to MAC addresses to make them stable for a while)
Is that the case even when ethernet is connected?
(I assume SSH has been enabled from /dev page when you had connectivity)

That would mean wifi actually never works, even if it gets a valid IP from your router…

Could you do this:

  • boot with ethernet & wifi
  • listen to some web radio
  • issue a log from /dev page
  • disconnect ethernet, and give it 30sec to settle (but do not reboot): does web radio stops?
  • check if you can still drive UI and play/stop webradio again
  • issue a new log from /dev page (if possible)
  • reconnect ethernet, and give it 30sec to settle
  • use UI to play/stop web radio (should work again)
  • issue a final log from /dev page

This may help seeing what happens when ethernet is unplugged/plugged and consequences.

Okay, to clarify:

  • SSH is enabled
  • Router is set to assign IP address to the RPi 3 wifi mac address
  • Ethernet on the RPi is automatically assigned to
  • When ethernet is connected, I can access the Pi on both .101 and .103 (web interface & SSH)
  • When ethernet is disconnected, I cannot even ping the Pi on .101

I’ll follow your steps in a bit.

Also strange, normally my router lists my device as audiocassette_WiFi and audiocassette_ethernet. They’re also displayed as different MAC addressess. Currently (plugged in to ethernet), the wifi is listed as “Static-B8-27-EB-CA-91-13_Wireles” (that’s its MAC address).
And to top it all of, I made a fresh Volumio 2.323 image for my RPi Zero W (this one was stable on it) and the same thing happens.

I’ll do a full router reset after your tests too.

Next try: reset the router.

Can you confirm Volumio Hotpsot is still turned OFF?

Did you set CRDA as advised earlier?

Under ssh, can you give output of:
cat /etc/wpa_supplicant/wpa_supplicant.conf (BTW do NOT create/alter the file manually)

Full reset of the router did the trick :smiley: :smiley: :smiley:

Looks like it was creating some sort of conflict with the MAC addresses which blocked traffic to/from the Pi. Probably because I gave my RPi 3 the same preferred address as my previous Zero W.