losing wlan connection after a moment on Raspberry Pi


nice Distro in theory. Unfortunately i got some big troubles to get it properly to work.

My biggest Problem at the moment is, that if i succesfully establish a wlan connection via the gui, i cannot connect to the Raspberry after ca. 5-10 minutes. As long as the connection work, the led on the wlan stick is blinking, but after a while it stays on and i get no connection.

I used this raspberry pi and this stick (a TP-Link TL- WN821N) with Raspbmc (and others) and there i had no problems with the wlan.

I already changed the interface to static ip and uncommended the eth0 interface, but this doesn’t changed anything: after a reboot i get connection and lose it after some minutes.

Any suggestions?

edit: i am using a hifiberry and ethernet is ineligible

same here… almost at the point of ditching volumio, unstable…


if i get it right, it’s a problem linked to the wifi dongle

in this forum, you have someone that describles his configuration of volumio and this wifi dongle ; this edimax is known to have some powersaving feature that has to be deactivated
it should help

personnaly, i tried plenty of things, but i suggest you try this first since it solved my problem
http://www.raspberrypi.org/forum/viewtopic.php?f=28&t=61665 : how to solve the problem when “Edimax Wifi adapter seems to go to sleep if not used”

if it is not enough, you can try this

if the problem still remains, google “raspberry edimax” and you should have others possibilities.

hope it helps


no, its definitively no issue of the wifi-dongle, because i get the same symptoms with ethernet. Thats why i kept posting in this thread: volumio-can-not-reconnect-after-few-hours-t797.html

Also, as i wrote, i use a tp-link dongle.

As you can read in the other thread, switching to volumio 1.1 solved the problem.
Thanks for your suggestions anyway. :wink:

Is there a solution for this problem?
I have a HiFiberry card and I keep losing ethernet connection over and over again - after some moments of inactivity. I also experience hangupps from time to time, sounds lik a scratched CD. Can be helped only by rebooting the system.

best regards