Lirc and 2.598

In the new version, 2,598, is there anything that interferes with lirc? I have a remote control installed that stopped working when updating. I don’t find anything weird.
Any suggestions?

Hi, did you get any further with the lirc problem?
After a power cut I have had to re flash and I too cannot get lire to work with 2.598

If it is any help my usual procedure is as follows.
Perform an update.
Install lirc.
Import a working lircd.conf into /etc/lirc.
Test using systemctl restart lirc and systemctl status lirc (showing the list of controllers)
All ok so far.
Next I edit /boot/configure.txt and add dtoverlay=lirc-rip,gpio_in_pin=23
Then edit /etc/modules adding these lines,
lirc_rpi gpio_in_pin=23

After a reboot issuing a ls /dev/l* command should show /dev/lirc0 but it doesn’t.
This procedure has always worked in the past.

Hello, here I have documented as I always did, and it always worked:
Now when I use the irw command to see if everything works, it tells me it can’t find the file, and of course it doesn’t work.

Just reverted to 2.583 and all is fine. Perhaps there is an alternative procedure to the one we are using that will work with 2.598?

Let’s wait for an update.
Your action is very good, we know that there is nothing wrong with the installation of Lirc.

The overlay has been changed with the kernel, try editing you boot/config.txt to the new gpio-ir kernel driver instead.

In my case it is like this:

initramfs volumio.initrd

Volumio i2s setting below: do not alter


####pin17 remoto

Can you tell me how I would modify it?



Not work…

Downgrade to 2.502 and work fine.

What does dmsg say?
I can update my version and try this weekend…

I made a downgrade to version 2,587 and it worked again, that is, there is a problem with version 2,598 and also with 2,599, I just installed it and it doesn’t work either.
After checking that all the necessary files are present, we see that it does not work:

volumio @ volumio: ~ $ sudo /etc/init.d/lirc start [sudo] password for volume: [ok] Starting lirc (via systemctl): lirc.service. volumio @ volumio: ~ $ irw connect: No such file or directory

If you are interested in seeing how I do it, here is described:

Many thanks ashthespy for your help. I have edited the boot config.txt file as suggested and this has got me past the ‘not seeing /dev/lirc0’ problem.

I still get the ‘no such file or directory’ error when testing with irw.

In the past, after editing the boot config.txt I have also added the lines;
lirc_rpi gpio_in_pin=23

But this has not helped.
I have also tried (not with much knowledge!)
gpio-ir gpio_pin_in=23
but no luck yet.

In case you are using the IR Controller plugin: I opened a PR on GitHub with a fix for the IR Controller plugin: