Linux-Headers for 4.19.60?


Is there a way to download the linux-headers for the kernel build for volumio 2.599 (4.19.60)?

I would like to populate the /lib/modules/4.19.60-v7+/build directory to do some compiles.

uname -a
Linux volumio 4.19.60-v7+ #1247 SMP Thu Jul 25 14:41:19 BST 2019 armv7l GNU/Linux



sounds like you mean raspberry. We don’t add our own kernel, it comes straight from the raspberry resources, so you would be able to get the headers files from there as well. You might have to google a little…

Thank you for replying.

I have googled a lot. I just can’t find any reference to 4.19 headers anywhere. Seems like they stopped at 4.9.x

Are you building the kernel yourself or pulling an already build one? If already built, can you post a link?

Thanks again.

Be glad to buy you another beer as well :slight_smile:

I did download the 4.19.60 kernel source (from git) and compiled it. Unfortunately, the symbol file did not line up with the kernel that came with 2.599. I am guessing that I did not have the right options.

I have spent 2 days trying to resolve the header file issue.

switching to 4.19 was not a very long time ago, 4.9.y was the latest before that, perhaps not everything is in place yet. I don’t think we can add much at the moment, the header files have to come from them…

Another approach:

Is there a way to build 2.599 from GIT? I see no references to 599 in GIT.

In other words - what is the build command to create the raspberry pi image for 2.599?

re-building the PI image can be done of course, but this is not going to help you much when you need the kernel sources for 4.19.60.

did you check this site: … -firmware/
That is where all the header files are.
Or clone the raspberry kernel repo and checkout 4.19.60, then take the “include” folder for your include files??

Very easy. from a terminal launch

volumio kernelsource

This will download kernel source and headers and prepare the environment for modules compilation.

This is absolutely what I needed!

Thank you!!!

This worked great on a Raspberry pi 3. My driver compiled and worked fine.

However, on a Raspberry pi 4, my driver would not load. I believe the problem is that the “volumio kernelsource” downloaded the symvers for v7 and not v7l.

The same sysvers file was downloaded on the pi4(4.19.60-v7l+) and the pi3(4.19.60-v7+).

I am guessing that the “volumio kernelsource” may need to be updated for the raspberry pi4 to download the symvers for v7l instead of v7.


Yes you are right, I will check it