LCD 16x2 via GPIO Problems // Raspdac Plugin?


I have a volumio project featuring a Raspberry Pi 3, a Hifiberry Dac+ Pro and a 16x2 hd44780 Display.
Until now I use the following plugins: autoplay and gpiobuttons.

I use the softshutdown included in the gpiobuttons plugin and wake it from pulling down Gpio 3.

But I struggle with the display, here is what it tried:

Raspdac from JedS: Changed the pin connections to mine and it works perfectly. But it fucks up the softshutdown. Volumio is kind of “restarting” and i have to pull off the plug in order to shut it down…
The plugin is written for the Audiophonics powerbutton, possibly is the problem is somewhere hidden in there. Is there any way to “deactivate” it and just use the display functions? A dirty solution is accepted as well!

hd44780-plugin from Saiyato: does not work at all. During the installtion process i get a frozen 16x2, displaying the current song. Does not refresh at all. Doesn’t work with the Pi 3 via Gpio right?

pydPiper from dhrone: I’m not able to edit the “pydpiper.service”.
This part works fine:

sudo wget sudo tar zxvf v0.3-alpha.tar.gz cd pydPiper-0.3-alpha
As far as I understand, I have to type the following in order to edit the pydpiper:

ExecStart=/usr/bin/docker run --network=host --privileged -v /var/log:/var/log:rw dhrone/pydpiper:latest python /app/ --volumio --driver hd44780 --width 5 --height 8 --rs 9 --e 10 --d4 23 --d5 24 --d6 25 --d7 26

Doesn’t work out tho, console says: “-bash: run: command not found”

If you have any ideas on how to make it work, feel free to share!

Update: The Raspdacplugin works fine!
I had to edit the ControllerRaspDac.prototype.onVolumioShutdown = function()
and comment out //self.softShutdown.writeSync(1);

New question: is there any way to turn off the LED Backlight on shutdown in 4 bit modus? It’s a LCD 162C BL (data sheet)which means i shall be able to control it via the d2 pin, right? Somehow it didn’t worked out for me, connecting the d2 to low didn’t shut it off. Swap to 8bit? Not that many gpios left…

i have the same setup, but for me is not working, can you help me?