scrobble doesn't work

Hello guys,

I would appreciate a help regarding to scrobbling. I have installed mpdscribble, activated in /etc/default/ mpdscribble, put username and password in /etc/mpdscribble.conf and after that restarted it without any reported problems. However, I cannot see in my account played songs, mpdscribble is just filling my journal file. Checking log files, nothing is reported as well.

I tried to open account to see is there any communication between mpdscribble and scrobbling sites, but nothing reported within also. Since there is no so much option to play, I got stuck and I don’t know how to push mpdscribble to fill instead the journal file in /var/cache/mpdscribble/lastfm.journal.

I installed new, fresh copy of Volumio and expected mpdscribble will work without any problems, since I have it installed and it worked on the old Volumio installation (1.5).

Thank you for your support.

Best regards.

Clock was not synchronized :slight_smile: Cannot believe it…


I was having problems scrobbling to lately and I could not figure out what was wrong.

How exactly did you sync the time ?

For me, the time differs at most 1 minute, it that too much ?

I thought the URL of their API changed

#url =
url =
username = sven-vc
password = …

What are you using ?


I have installed ntp server for time synchronization and made a link between /etc/localtime and /usr/share/zoneinfo/Europe/Zagreb (there is a number of time zone files in this directory, you should make a link with that which you belong to).

But firstly, I entered in /etc/mpdscribble.conf in verbose line value 3 to have a full log to see where is the problem. In my case, the time was the problem…and yes, with 1 minute difference :slight_smile:

I use and it works now.


Thanks a LOT !

I switched back to using, installed ntpdate, started the ntp service and restarted the mpdscribble service and now scrobbling works again.

Super !