Issues with stability and spotify plugin

Hi all,

maybe some of you have similar issues as I am discouraged with Volumio stability, (running latest version of Volumio 2).

My setup is:

  • RiPi 2 & 3 (Tested with both)
  • Mamboberry LS DAC+ powered with separate very low noise 25VA power supply.
    On Amp side, I am equiped with Marantz PM-75 and ReVox speakers Symbol B MKII. Sound is mmmm crisp.

Here are my issues:

:arrow_right: general stability issues. Volumio is for me buggy so much that it is literally unusable. GUI is not working ok there are small bugs there and there. What disturbs me the most is:

:arrow_right: Spottify plugin (especially in hi quality streaming mode) works only occasionally, several clicks and may be just maybe I can make it work. After restart, to say if I go directly it works fine or until you click around in the web interface.
In out in out and I can block it so easily that only restart helps.

:arrow_right: Automatic switching between sources (any sources):
Example Start Radio -> switch to any other source will not play new song. UI will show it is switched but DAC still plays old song.
Only if I woul previously press stop.

:arrow_right: Volume mixer doesn’t work. I assume that this is bc my DAC has no hw mixer. Why software mixer is not worky? :slight_smile:

:arrow_right: not trying to be smart here but image takes quite some seconds to load. (compared some other players on the market).

Since my friend have same RiPi setup , he experienced exactly same problems.

Any experience you cold share from your side?

thanks and best regards to all of you

Yes, there are bugs … please report individually as you find them, so that they can be worked on. I would take issue with “literally unusable,” it works fine for me (generally) on a daily basis.

Not something that I have seen, except once when I was having wifi problems. If possible, try it wired rather than wireless, and see if this makes a difference.

When you select something such as a web radio, it is added to the queue. If you then try and add something from, say Spotify, it is appended to the end of the queue (after the webradio which is playing constantly). So you need to clear the queue. What is indeed a bug, and was reported yesterday, is that the UI shows the wrong thing playing.

In what way is the software mixer not working?

It take time to boot up from scratch. Personally, I tend to leave my main player running.

Please remember that Volumio is very much a work in progress, keep reporting the bugs, and we can build something really great :smiley:

Hi thanks for answers,

Didn’t want to insult anyone with statement that it is “unusable”, as it is related only to my case… and I am new here.

Work of developers and community is appreciated. Thanks guys for great achievements. You and your site actually made me go into adventure of RPi +DAC. My intention was to give valuable and and constructive feedback (mixed with some frustration) . :slight_smile:


  • I am not using WiFi only Ethernet. WiFi is disabled.
  • it is very important for me that spotify works.

ok thanks for that.
Implemented queue handling is for me confusing. So primary action is “add to queue” not play the song. Ok didnt get that :smiley:
Other apps and spotify for example have a bit different logic.

Software mixer:

  • is not working, as soon as I select software mixer and apply changes, I don’t hear sound any more.
    (I must admit that : this is less important as it diminishes quality of steaming, but I couldn’t make it work.)

based on your advice and feedback I shell test it more. Thanks once again.

Do you think older versions are something you would recommend testing?

Would you mind sending a log report, to see if there is anything obviously wrong? Reboot your RPi, try once to use spotify, and if it fails, then modify the IP address of your Volumio UI to include “/dev” eg.

Fill in the ‘Send Log or bug report’ field making sure to include your username first, and press send.

Ok thx

Sent from my SM-G935F using Tapatalk

This feature is not available yet, since it will be included in next release… :wink:

Oops, sorry :blush:

OK, if you have access to the command line (either through ssh or by keyboard/monitor), then type in:

sudo journalctl -f

try to access spotify, and see what errors the report throws out.


I think you will understand better “my case” now:-)
After one song is playing, when I select anoter song and place it the queue from different source volumio wont play it.

here is the procedure for TEST1 - I have video as well.

  1. boot RPi. No errors observed.

  2. click on Browse -> My Libary -> NAS -> play it
    effect: I can hear the sound

  3. click on browse ->spotify -> my playlist
    effect: I see the play lists

  4. click on one of the play lists
    effect: I see the songs in playlists

  5. click on the song :
    effect: it is added to queue

  6. click and check Queue:
    effect: both songs are in queue

  7. click skip to play next songs
    effect: nothing happens.

  8. click on play to play the song
    effect: nothing happens.

not on the video:
9) go to browse ->spotify -> my play list
effect: I cannot enter anymore playlist

after this only reboot helps to play any files:

Files attached:

Can you please help? I cannot use volumio like this…
SpotifyError.7z (1.2 KB)
TEST1.7z (1.88 KB)

I just tried another player available on the market, and all works out of the box without any any problems (with same hardware).

cheers, I hope someone has ideas why my setup is not working.

OK… I am done with this version of voluimo switching to rune.
no patience anymore. Will check next version.

Thanks and keep up the good work.