Issues with scan of music files on NAS

I’m setting up my first Volumio build (never had a need before). And I’ve added my NAS music location, but when I scan, the number of artists increases then disappears. Gets to mid 100-200 and then disappears.

Raspberry Pi A+ (I had it spare),
16GB generic card,
Amazon Kindle Fire charger,
GPIO control v0.0.1
Volumio v2.619 image (2019-09-24)
Static IP,
USB ethernet adapter,
3.5mm audio out.

NAS mount options…
IP = 10.0.0.x
Path = audio
Options = ro,vers=1.0,nosetuids,sec=ntlm,nounix

I start a rescan in the My Music section and it will fairly quickly add music to the database. But after it’s gotten to about 150 artists, no artists will be found in the library an nothing is in the table on the My Music. After this it will continue to flash the activity and network lights (as if continuing to add artists), but nothing is found in Web GUI. I’ve left the Pi overnight and in the morning there is nothing in the library and table in Settings -> My music is empty.

I’ve tried rebooting after the rescan but I still cannot find my music anywhere. I was wondering if it is a RAM issue, as I’m using the A+ with only 256MB of RAM, the Web UI is fairly slow. I used an A+ as I had one knocking around spare (same with the USB ehternet)!

Any help would be great.

I got similar issue after upgrading from 2.587 to 2.599 , NAS scan stop at the begging without discovering most of the Album on NAS

I deleted and declared again and as well made a from scratch installation without success.
As well, I tested the disk. No issue.

And last upgrade to 2.632 did not helps.

It is just stopping at 47 albums - that is all and mdt.log and volumio.log doesn’t not report any particular error.

I generated logs and debug info and send it here :

Thank you very much for your help.

I got exactly same experience on x86 platform, scanning of NAS drive got just frozen. Nothing helped, new fresh install, another device, etc.
My library on NAS is about 3 TB mostly hi-res music.

Thank you in advance for help.

Nothing obvious from the logs…
We are investigating

Do you need another set of logs ? issue is still there…

Upgrading to 2.657 definitively solved the issue…

I am very sorry to say, that on x86 platform the problem is still existing.
Scanning of NAS drive just got frozen (on same position) as before.

With the latest version 2.668 is no progress, sorry. Scanning just got frozen at the same position as before…

Latest version 2.671 did NOT resolve the problem with scan on NAS … sorry

Same here RPi 3B+, V2.668, Synology Nas and 90.500 tracks.

Temp. Solution 6 times rescan.

Even version 2.673 is NOT a solution for full scan of NAS. Still it stops at the same position.

Also version 2.692 is not a solution for above mentioned issue.

As I already mentioned in other similar tread, this behavior can be caused by damaged audio file (possibly incomplete download). I got around this problem by adding to library in portions, until I found damaged file and deleted it.

So I tried to get my music library in many different parts/ways into the Volumio, but it was a bit crazy … results were almost random number of albums/tracks.
But the same NAS (Synology) is without any problem scanned by KODI or by Groove, so it is NOT a problem of bad files.

This issue is solved in current version, 2.698
Thank you!