Issues With Rpi Zero W & Version 3

Hi All

I have been pulling my hair out with this one for a while.

I have some older RPi ZeroWs and i thought they would be useful as multiroom devices. The initial set up was the latest version of Volumio3 with a HiFi DAC+ Zero. I couldn’t get this to work properly at all, either no sound, sound but no volume control or Failed to open ALSA Device. There were some forum posts regarding HiFi Berry DACs, so i thought perhaps its a DAC issue, so I Bought an Allo Boss DAC. Now I Just get Failed to open ALSA Device.

  • Is there a know issue with older RPi Zeros and Ver3?
  • Has anyone had similar issues?
  • fixes workarounds please?


PS and i mean this in the nicest way don reply with a comment you understand because why doesn’t everyone know it, i want simple plain English Explanations Please!!

I have a few Raspberry Pi Zero W worning fine with Volumio3 since long time.

I sometime encounter the ALSA error you describe if I use the MPD_OLED plugin.
Please try to disable the startup sound and reboot, in my case it helped

No plugin, but i will try disabling the start up sound


One remark: the multiroom feature is quite cpu-intensive on the master device, because it must transcode on-the-fly the incoming audio stream to flac, for delivering it to the slave devices. This could be too much for the slow single-core CPU of the Raspberry Pi Zero, definitely less of a problem with the Raspberry Pi Zero 2 (the new one with quad-core cpu)

I agree with Darmur: with the Pi Zero W you pretty soon run into performance issues. It works fine with web radio and audio samples at 44, 48 or 96kHz, but that is about it. Try playing a DSD256 file on a Pi Zero W, and you’ll know what I mean.

yeah my master device is an x86 thin client, the pi zeros would just be remote devices

yeah wont be used as the master or hi res files

Update and I don’t know how this worked, but I used a pi3 that I had, used the same SD, and the boss DAC. All was fine worked ok. Swapped the DAC and SD back to the pi zero, still working ok, can’t explain it but it’s working

that’s strange, but good that you solved!