Issue with my new RPi5-8GB

I had a scheduled appointment with Volumio support team which he’s supposed to TeamViewer in to my computer this morning at 6:40am Jan 24, 2024 (pacific time). There was NO one checking in. I guess I’ll go through this channel and may be there is someone out there who might have the same problem and perhaps a solution.

The only problem that I have with RPi5 is Volumio imported only about 10k songs (I have >100K) from my Qnap NAS and it stops. It’s a fresh install with no plugins at all. I’ve never had this issue with my RPi4-8GB, RPi4-4GB nor TBS.

Here’s the link to my log.

Device Unique ID Code: 413e1b808dca51b76f0f810b3fd0cfdc

My work around is to have everything installed and ALL music added in the RPi4 and use the SD card on the RPi5.

Thank you.


I am so sorry to hear about the missing appointment. We are investigating.

Regarding your issue, in the log I just see that mpd crashes, for no apparent reason. This is going to be very tough to diagnose…

On the other end, we are about to release a new version with updated mpd, which might definetely solve this issue. If you feel, you can put your device in test mode and update to 3.601. Let us know how it goes

Thanks for a quick response. I also installed v3.601 on a different sd card and it’s the same.

Here’s the log.


Here is a log from fully working sd card which was installed and music added on RPi4 and running on RPi5. All >100k songs are there.

In both cases it looks like it stops at

NAS/Qnap/@Recently-Snapshot/GMT-08_2022-04-27_0100/_Unfiled Songs/Randy Travis - Forever And Ever Amen.mp3

Can you try to remove the folder: @Recently-Snapshot ? (I assume is a temp folder for backup purposes)
Or the unfiled songs folder?

Dear Andy,

Davide from tech support,

I apologize for any confusion.
The TeamViewer appointment was scheduled correctly, but it seems you did not accept the TeamViewer invitation in time, which is essential for direct access to your PC without requiring the password.
I regret any inconvenience caused, as without this acceptance, remote connection becomes challenging.

About the issue, we can go through it via ticket thread.

thanks for understanding


I just import 1 folder (My Music Lossless) and it’s still having the same error.

No problem. I can provide you information via this thread or if you need to TeamViewer again, I can switch to my Windows computer.


This is really a tough nut to crack.

Can you confirm the same version can scan (from scratch) the very same NAS share on PI4?

Unfortunately the logs do not tell much, just that mpd fails without any log whatsoever…

The RPi4 and TBS don’t have any problem importing music. Here’s a screenshot of my RPi4-4gb just now.

I pulled the SD card from RPi5 and update the music on RPi4 and there was no problem at all.

Then I deleted the NAS and pulled the same SD card from RPi4 and update the music on RPi5 and there was the SAME issue happened! This time it stuck at 8,666 songs, not quite make it to 10k.

Are you connected via WiFi or lan? If lan can you try the same but on wifi only?

I turned off lan and used wifi only. Same issue and very slow updating until stopped at 11085 songs.

Hi Andy!
I have similar problems with Rpi5 and my NAS so I guess I will stay on Rpi 4 and some PC:s for a while until problems are solved.

BTW Thanks for helping me out the other day!
Regards/ C

The work around is to install and add music on RPi4 and use it on RPi5.

Yes, I saw that in an earlier post of yours.
Regards/ C

1 Like

I tried 3.616 but still having the same issue. Music scanned up to about 11k songs and then stopped. I have about 120k songs on my NAS.

Fresh installation v.3.616
No plugin

Can someone help?

Here’s the log:

We are investigating the issue, this looks to be a tough one…

** Problem SOLVED **

Today I saw a new updated v3.629 available, so I flashed a new SD card with the 3.616 (official version) and installed on my RPi5-8GB. Before I configured anything, I updated it to v3.629.

The very first thing after update was to add a network drive. My network drive is a NAS from Qnap which has over 100k songs in my music library. I’ve never had any problem adding all my music from my NAS to either RPi4 or TBS, but with the new RPi5, the added music always stopped at around 11-12k songs on all Volumio versions below 3.629. The workaround if I wanted to use the RPi5 was to install and fully configured on RPi4 and use the SD card on the RPi5.

Today, the problem was solved, and now I have all my 100k+ songs imported successfully. I don’t know what caused the problem and how v3.629 fixed it. Thanks to the Volumio team that keeps trying to solve the problem, and finally they did it.

Current set up:

Volumio - v3.629
Touch Display Plugin - 3.3.8
PeppyMeter Plugin - 1.4.1
Spotify Plugin - 4.0.4



How did you manage to obtain this version 3.629 ?

She is not available for me and I also have some problems with indexing some music albums.