Issue with Moon 100D DAC

Hi all,

My DAC doesn’t work with my Moon 100D DAC. I don’t hear any sound when it is plugged. There is sound over HDMI.

I tried to use the DAC over a powered USB hub and connected to the Raspberry Pi

volumio@volumio:~$ uname -a Linux volumio 3.10.25+ #622 PREEMPT Fri Jan 3 18:41:00 GMT 2014 armv6l GNU/Linux

It doesn’t show in alsamixer. Here’s the output when I plug it in:

volumio@volumio:~$ dmesg [ 1978.715731] usb 1-1.3.6: USB disconnect, device number 7 [ 1992.920791] usb 1-1.3.6: new full-speed USB device number 8 using dwc_otg [ 1993.205245] usb 1-1.3.6: New USB device found, idVendor=08bb, idProduct=2705 [ 1993.221532] usb 1-1.3.6: New USB device strings: Mfr=1, Product=2, SerialNumber=0 [ 1993.236785] usb 1-1.3.6: Product: USB Audio DAC [ 1993.248990] usb 1-1.3.6: Manufacturer: Burr-Brown from TI [ 1993.268259] input: Burr-Brown from TI USB Audio DAC as /devices/platform/bcm2708_usb/usb1/1-1/1-1.3/1-1.3.6/1-1.3.6:1.2/input/input2 [ 1993.292288] hid-generic 0003:08BB:2705.0003: input,hidraw1: USB HID v1.00 Device [Burr-Brown from TI USB Audio DAC ] on usb-bcm2708_usb-1.3.6/input2

When I run “lsusb -t” I noticed there is no driver for the DAC:

|__ Port 6: Dev 7, If 0, Class=audio, Driver=, 12M |__ Port 6: Dev 7, If 1, Class=audio, Driver=, 12M |__ Port 6: Dev 7, If 2, Class=HID, Driver=usbhid, 12M

When I plug the DAC in my laptop (running Ubuntu kernel 3.11.0-15) I see a driver being loaded:

|__ Port 1: Dev 3, If 0, Class=Audio, Driver=snd-usb-audio, 12M |__ Port 1: Dev 3, If 1, Class=Audio, Driver=snd-usb-audio, 12M |__ Port 1: Dev 3, If 2, Class=Human Interface Device, Driver=usbhid, 12M

Is there any chance I can get my DAC working with Volumio? Thx

I got it working this morning by enabling the “C-Media” fix then I had to reboot the Raspberry Pi. When I run the “lsusb -t” command I now see the “snd-usb-audio” as the driver. And the DAC shows in the Playback page.

I disabled the “C-Media” then reboot the Raspeberry Pi and now it seems to work all the time. Will do more test tonight with the audio gear connected to the DAC.

Apparently it needs more than the “C-Media” fixe for the DAC to work. I tried the kernel at this link:

The same problem reappeared, and setting the C-Media fix didn’t helped. When I reverted to “Linux volumio 3.10.25+ #622 PREEMPT” kernel it started working properly again. Anyone have an idea?

When I have it working it sounds wonderful! Thx for Volumio

Finally the “C-Media” fix seems to be the cure for the SimAudio Moon 100D dac!

With the new kernel I had to remove the option “options snd-usb-audio nrpacks=1” from /etc/modprobe.d/alsa-base.conf since it was preventing the snd-usb-audio module from loading.