issue on RPi4: no audio-jack working

Hello. I installed last Volumio version on microSD for running Raspberry Pi 4B (4GB). It runs fine, but playback sound-out is not working on audio jack. Any idea how to fix this issue?? Thanks.

Confirmed; I have the exact same issue. Also with a RPI 4 with 4GB memory. I’m using the latest version of the software:
VERSION: 2.599
RELEASE DATE: 02-08-2019

I have no clue if the 4GB is related though; I don’t have 1/2GB board to make a comparison.

I’m interested in buying a DAC soonish; but I’m a bit in doubt which one to buy. Allo Boss 1.2 still seems a safe bet. But then I wonder if a DAC might contribute to the warmth of the RPI4; And I’d like to have a proper casing for the RPI4 including the DAC. So I think I’ll have to wait a bit here…

BTW I don’t think this is “MyVolumio” specific though.

Maybe this thread should have been categorized on “Help and troubleshooting”:

Have the same issue as well with 4gb pi

Verstuurd vanaf mijn SM-G960F met Tapatalk

Updated today to : 2.609 / : Wed Sep 11 00:47:44 CEST 2019
Still no sound with Volumio.

I didn’t verify though, if I do have sound through something like Raspbian. Did anyone validate this (just to validate that the RPI4 with 4GB has sound through the Jack with another OS)?

I’ll try it anyways, but I’ll wait until I have a spare micro SD card

While trying to play an MP3 file, I noticed the following weird behavior:
Every time I adapt the volume level, the song seems to go back to the beginning of the song… My hunch is, this is ALSO an issue when you have a DAC hat.


We are investigating. I confirm jack does not work on PI4

is there a work around for it. Our can i install a previous version of volumio

No workarounds, and previous versions won’t work on PI4

v2.609 installed on Raspberry Pi 4 [2GB] on 8GB microSD
No sound thru headphone jack. Works on a USB to 3.5mm adapter though.

Clean and validated install on memory card.

are there already developments

Have the same problem.
Would be nice if there is a solution.


Verstuurd vanaf mijn SM-G960F met Tapatalk

No solution yet. I don’t find any info on the new audio modules with the latest kernel.
Any pointer is appreciated

Same situation. On raspberry Pi 4 and volumio 2.599 no sound from jack. What’s interesting on experimental build for raspberry Pi 4 version 1.026 i have sound but this version is not working properly (plugin problem, restarts).

Thanks for the pointer, that’s very useful

even with version 2.619 the jack out doesn’t work on a raspberry pi4

I tried the same thing :smiley:
But I didn’t have high hopes since the release notes didn’t mention it anyways. I guess still a work in progress :nerd:

Not sure if it will help you in any way. But here we go :slight_smile:
On the 4th OS I’ve installed, I finally had sound with my Rpi4 from the audio jack:
LibreELEC with a fresh install from Noobs. Just out of the box as is.
In LibreELEC I noticed the default audio output was set to HDMI. I switched the “Audio output device” to “PI: Analogue”. Then it started to work.

Earlier tries, where I didn’t manage to get sound from the audio jack:

  1. Raspbian. Which also didn’t work after apt-get update/upgrade
  2. Moode
  3. Laka; also from Noobs. Did an upgrade to v 2.3.1. But still didn’t have sound.

Maybe the 3 other options could work as well. I’m not so familiar with those systems though.

Just did an update to VERSION: 2.632
I have sound over my audio jack :slight_smile:. I’m currently streaming internet radio. Haven’t tried anything else yet.

Great work; And finally able to enjoy music on my new RPI4 :smiley:
Enjoy the weekend.