Is there any way to rebuild the full database from scratch?

Looks like mpd database is hanging on to some old stuff. e.g. I changed the Artist in one of the Albums because it was spelled incorrectly. However, it now shows both (2 times). I would like to completely delete the database and rebuild it all over again. Is there a simple way to do that? I am using MPDroid and MPad as clients. They both show the old and the new changes (duplicate). So I am assuming it is the mpd that is feeding them that info. If there is no way to clear it, then can I somehow just delete the mpd.db file and have it build it again?

I would appreciate if anyone could help. Thanks.

I’ve had the same problem but with the library view. I could fix this by going to the menu in the library and started a reload. This took a while and I had to run it twice but it helped

@canbonbon: I’ve never seen such duplicates when renaming an artist, normally when you update mpd it should add the new one AND clear the old one. Are you sure that you didn’t leave a track somewhere with the old artist name? It would explain the duplicate. Check also your “album artist” tags.

@MobeyDuck: I guess you’re talking about the “new” library you’re beta-testing ? It’s currently not connected with MPD update commands, that’s something I still have to work on, so yes, when you change your MPD db, you have then to explicitely refresh the library. I’ll do something for that before release. However I don’t know why you had to reload it twice…

I have the same problem here with duplicate songs (with version 2.029). I tried to remove the album folder from the external usb and rebuild and updated the db from the menu, restarted volumio but it would still show the album. I recopied it onto the disk, rebuild the db and now it shows the album twice.

Is there a way to drop the db - for example from the console - and then rebuild it? Or will this destroy the installation?

From my music, hit the rescan button.
Leave it alone and let it finish, you’ll see

Well, it didn’t work for me. I still have the whole cd twice. I double checked that really have only one copy on the disk and I emptied the playing queue before the rescan (and refresh). I tried it with a restart also. Is there a way for a hard reset like deleting a db file?

Thank you for your help and great work.

Check your recycle bin. I had a similar problem after I retagged and it was because the old version was in the recycle bin. Once I cleared that it was fine.