Is it just me, or is not possible to play music over USB?

Hi there,

Just decided to give Volumio a try after having spent a lot of time on rAudio.

Installation of latest version went without any problem.
I could access the Volumio interface with both computer and android smartphone.

But to my great surprise, when I went to the music output, I was offered a choice between :

  • HDMI
  • headphones.

I have no option to play sound over one the 4 USB outputs of the Raspberry Pi4.

Am I under the impression that there is something missing there ?
Did I do something totally wrong ?

Needless to say that, whatever I choose (HDMI or headphones) my USB DAC receives absolutely NO SIGNAL.

In rAudio I could select “Exynos” as output and then everything was fine…
So could I with Moode Audio.

Why does that not exist in an advanced commercially supported software ?

Thanks for your answers.



(P.S. : I think that HifiBerry OS is based on Volumio and shows up the exact same ptoblem).

Yes, the USB DAC should show up as an output choice.
From the information you supplied, I don’t think you did anything wrong.
But it would help if you would let us know what DAC it is.
Also post the URL of the logfile you can create with the log function from the dev page.
Howto: Send a log

It isn’t :wink:

As a DAC * would like to use my Fiio M11 Pro DAP.
It is based on Android 7.
It sports 2 X AK4497EQ DAC’s and I like the sound of AKM DAC more than the sound of ESS DAC’s (probably totally subjective).

Can’t create a log right now as I already went back to Moode Audio. But I’ll probably be able to find some time to go back to Volumio again… Takes like literrally 5/6 minutes :slight_smile:

The confusion about HifiBerry OS and Volumio was because they share the same build number, which is not that common I think :slight_smile:

I presume you used the Fiio settings to switch the USB mode to “DAC” before you tried?


LOL. Yes, I did :slight_smile: That would be a common mistake to forget to do that.
But yes, I did that.
I even plugged it out and re-plugged it in so maybe Volumio can detect the change…

BUT : I also have another dedicated DAC. And AUNE S8 (and also the AUNE S6). Both can be connected via USB. And I get the same result : no DAC detected :frowning:
Other RP 4 OS can detect the DAC as “AUNE S8” or AUNE S6 USB DAC.

Weird :frowning:

EDIT IMPORTANT : Took out SD Card and reflashed Volumio. Now everything is working as it should… All DAC’s, including M11 Pro AK4497EQ DAC recognized a “Exynos”… Same as others :slight_smile:
So probably went wrong on first flash of Volumio…

EDIT 2 : Even though I managed to get Volumio to work, it seems it unfortunately does not fit my needs. Unfortunately because if it would be working it would be really nice. But for some unexplainable reason, every 5/6 minutes, the sound get’s completely scrambled. It is like the DAC goes out of sync… I have to pause the track and then relaunch it and it works well again… until it happens again. I assume there is a “hidden” setting somewhere that may allow me to use a different alsa “tunnel” (Moode allows to use hwdirect) to solve it. But until I find out if that setting exists, I won’t be able to use Volumio… and I deeply regret it :frowning: