IQAudio Pi DigiAmp+ and NAS


I have read and read this forum and completely pickled my head.

I cannot get my NAS (WD MyBookWorld with 10,000+ music files) to mount in volumio. I have tried numerous ways of doing so via ssh, all to no avail but willing to try again.

What I have done most recently, connected via ethernet.

  1. Configure IQAudio as the DAC.
  2. On reboot, confirm audio is working with radio via volumio.local, enable ssh via volumio.local/dev
  3. Confirmed NAS IP address, and the share folder (192.168.1.xx, Public/Music), make sure everything is enabled and access for all users
  4. SSH into volumio, edit /etc/mpd.conf to allow mpd logging.
  5. In WebUI, My Music, Add New Device. It doesn’t find it with auto scan so I enter the following:
    Alias: Music
    NAS IP: 192.168.1.xx
    Mount: Public/Music/
    This gives me confirmation at the top that its mounting and updating library.

tail -f /var/log/mpd/mpd.log cannot open '/var/log/mpd/mpd.log' for reading: No such file or directory tail: no files remaining

Tells me that there is no such file or directory, I have to mkdir which I can then cd into.

On the WebUI my connection is showing a red cross so (truncated version):

mount ....lots of code.........//192.168.1.xx/Public/Music/ on /mnt/NAS/Music type cifs (ro,relatime,vers=1.0,sec=none,cache=strict,domain=MYBOOKWORLD,uid=0,noforceuid,gid=0,noforcegid,addr=192.168.1.xx,unix,posixpaths,serverino,mapposix,acl,rsize=61440,wsize=65536,echo_interval=60,actimeo=1)

I go into WebUI, double check options for the NAS, press Save and I get the white rotating circle this time so

tail -f /var/log/mpd/mpd.log Sep 20 23:29 : zeroconf: No global port, disabling zeroconf Sep 20 23:29 : exception: Failed to access /var/lib/mpd/music/NAS/Music: No such file or directory Sep 20 23:29 : client: [0] opened from local Sep 20 23:29 : client: [1] opened from Sep 20 23:32 : client: [1] closed Sep 20 23:32 : client: [0] closed

At this point WebUI is completely frozen to me, nothing else is appearing in the log, so in terminal I reboot.

Once the WebUI is able to load again, I can no longer listen to radio, the mpd directory I created earlier is no longer there and I have to factory reset volumio to get it working again. Additionally, the failed to access directory from the log is there so I don’t know why it can’t access!

I feel like I’m going round in circles and I’ve no idea what I’ve done and not done now, so I’m hoping someone will have some advice ie how do I get the mpd log directory to stay forever, how do I get the NAS to mount??

So, the UI indicates that there is a mounting problem. Have you tried the path name with a leading “/”?

I figured out the problem… I had forgotten to reboot my NAS!