Installing Volumio on EXSI Virtual Machine

I have installed the x86 img by injecting it over ethernet (netcat) , on a Vmware EXSI 6.7 virtual machine.

I´ve got the VOLUMIO splash logo (EFI, tried with BIOS, with same results) and the infamous msg of cannot find volume UUID xxxxxxx.

I have searched the forum but with no luck.

Any idea on how to fix it, please?

Hi snaper, welcome to Volumio. :slight_smile:

Firstly VMs are not supported officially by Volumio, however a number of people use them successfully.

Hopefully someone from the Community with more knowledge will be able to come to your aid.

I am immediately concerned by your reference to “injection over ethernet”, and I do not not know what an EXSI VM is. Volumio uses a squashfs overlay, which perhaps does not behave as you would perhaps expect with a “normal” image.

I was able to install it on ESXi 7 but you need a USB drive with the Volumio image loaded.

Thank you!

The thing I tried to do is to create a VM of volumio to use as a server and snapcast receivers to play the music (without local audio DAC)

About the “injection process”:
Booted a VM with a Knoppix Live CD, from then , execute netcat and set it up to listen in a port for data and redirection to dev/sda.
From another machine I sent the img of Volumio as raw data by using netcat to the VM.
This was done by others with success, but in my case, when I boot up, the machine shows the splash logo an then the “cannot find UUID blabla” error and the terminal.
I have observed that it doesnt take so long, so I suspect that maybe not everything is written to the virtual disk, but I don’t know why because netcat has no feedback whatsoever.

Let’s see if there’s somebody with the same issue and can pour some light .

Thank you again.

Could you describe the steps to doing accomplish this?

I can think of creating a debian x64 machine, and passthru the usb with the image burned on it, but you keep the usb for booting each time or you install it to the VDisk?

Thank you in advance.

  1. Using StartWind V2V converter, build a new VM in ESXi using the Volumio image

  2. Flush the Volumio image on a Flash drive using Rufus

  3. Inset the Flash drive to ESXi host and pass-through it to the Volumio VM created in first step

  4. Now boot the VM and it will pick up image from Flash drive and deploy itself

  5. Don’t remove the Flash drive, Volumio will always this this drive to load (VMDK to boot, Flash drive to load)

Well, the thing was to install it inside the vm. But I am starting to accept that it will be with usb boot each time…

I’ll try your method (At the moment I have the VM created with the other method, but it should be fine too, as it has the sh console working ) I will flash the img to the pendrive and passtrhu it to the VM and see what happens…

I appreciate your post.

Thank you very much.

I am not very well versed with ESXi - but shouldn’t it be possible to attach a virtual boot drive, instead of a USB pass through?

If so you can follow a similar method as Virtualbox to convert the .img file to a VMware virtual disk. For Virtualbox you could get away with vboxmanage convertfromraw

Good point, I can boot from a virtual DVD drive, it should be possible with usb as well, I’m going to dig into it, I’ll let you know if I can make it work.

Did anyone ever figure out how to make this work without needing a USB drive? I wasn’t able to figure out how to convert the .img into an .iso that would boot in VMware.

Pl Follow the instructions its simple.

Download the x86 img from the site.

Use starwind converter to convert img file to vmdk file.(non growable vmdk for esxi server)

Create a new vm with <linux<debian<6<64bit.

edit and remove the default hdd.

upload both .vmdk and vmdk config files to datastore location.

Now Edit the Created VM and add sata controller.

Add existing hdd pointing to uploaded vmdk file.

Then double click the attached hdd and change the controller to sata.

just start the volumio it should be working correctly.

not allowed to post more then one image in the post.

(Ignore the Indian grammatical errors)