Installation Procedure for 2.587 on an RPi

Hello — I have been using Volumio on RPI’s with 2.3xx and 2.4xx Releases since Mid 2018. Once I got things working, I did not update.
My DAC is a Generic I2s type and my music is on a USB Flash Drive. Connection was made to a Stereo Receiver with speakers and everything worked as it should as far as my Flash Drive Music Library.

A few days back I attempted to install Volumio 2.586 and when that did not work, I tried 2.587 and it also did not work.

I went to, selected DOWNLOAD, and after arriving at the D/L page for RPI downloaded 2.586 and later 2.587.

I followed the Installation Outline at the Bottom of the Page — USED a PC with Windows 7 and an RPI 3

  1. used SD Formatter to format the micro SD card.

  2. used Etcher to flash the volumio image

  3. transferred the micro SD card to the RPi and powered it up and saw RED & GREEN LEDs … waited 15 minutes for the first power up to complete … RED LED only.

  4. powered up a NEXUS 7 Android type ipad, checked wifi in settings and saw I had wifi on my Stew network. I selected volumio from the list of wifi’s and responded with volumio2 as the password. Stew was saved and Volumio was active, but with no internet specified.

  5. did a from the Chrome Browser and got into the VOLUMIO CONFIGURATION AP. Selected English, named the Volumio WiFI network as Volumio-dac82, took the Dac options I2s, I2s Generic, then selected the ALL VOLUMIO OPTIONS Option, then answered the question about the WiFi Network to use when Volumio came up and entered the Stew Network Password.

  6. did a Volumio RESET when Requested … waited 10 minutes and powered the RPI and NEXUS OFF.

  7. attached the RPI and DAC to the Stereo Receiver, powered the RPI UP and waited 10 minutes.

  8. Powered UP the Nexus, checked the WiFI Settings, had WiFI from the Stew Network, Volumio was not in the List of Wifi Networks.

  9. Tried the http:/ URL and the Volumio AP never came up. Powered the Nexus OFF

  10. Powered the Nexus ON, tried Volumio-dac82.local … the Volumio AP never came up.


Hi stew67,

Did you try without WiFi (LAN cable only) ?
what type of PI do you use ?
what type of “generic DAC” do you use ?

Best Regards

Hi Josef — I am using an RPi 3B and the Generic I2s DAC is a TDA-1387-8 which has worked with RPi 2/3/3B using Volumio before the 2.5xx Version.

Before I wrote down the steps that I followed for Wifi, I also tried the Bottom Of the Page procedure using an ethernet cable from my RPi 3B into my router. I was able to configure the Volumio AP from the Nexus Tablet and do the reset when requested, then powered down.

Unlike the case in my forum Help Plea, the Volumio AP never asked about what WiFI Network to attach to???

After connecting the RPI/DAC to the stereo receiver and powering up the RPI, I got nowhere since the volumio was not in the list of wifi networks and I don’t have 50+ foot ethernet cable. If I remember correctly, the browser said the server did not respond or Timed Out???!!!



That is exactly how it is supposed to be! :wink: Look at your Step 5: you gave Volumio the details to connect to your “Stew” network.
Volumio only starts its own wifi hotspot (the “Volumio” network) for configuration purposes, when no internet connection is configured or available. During the configuration the wifi network is set, as you described in your Step 5. After the reboot the “Volumio” network no longer appears.
From now on the Volumio AP can be accessed from any device connected to your “Stew” network, either via the browser with “volumio.local/” or its IP address, or with the Volumio app (this will automatically detect the device). Give it a try!

Quick question: how did you do this? When the configuration wizard finishes, Volumio will automatically reboot. No need to do that yourself or to disconnect the power. It is highly discouraged to disconnect the power without proper shutdown, as this gives a high risk of corrupting the Volumio installation.

Hi PaulM ---- well after getting nowhere with Versions 2.586 and 2.587 I downloaded version 2.526 and completed the process

  1. download

  2. reformat the Micro SD

  3. flashed the Micro SD with the 2.526 img file using Etcher

  4. hooked the RPI/DAC up to my router via an ethernet cable

  5. powered up the RPI/DAC … waited 10-15 minutes until no green LED visable

  6. powered up my Nexus Tablet

  7. used browser to http:/ or Volumio.local and answered the questions asked by the Volumio Startup AP, and then did a power down when the AP directed Restart or Power Down. Also powered down the tablet

  8. Then I powered up the RPI/DAC and waited about 10+ minutes

  9. Powered On the Tablet and went to Settings/Wifi and my Stew Network was active. Clicked on Volumio and it became active

  10. connected DAC L/R Audio Output to my receiver, powered the receiver on

  11. browsed to either or volumio.local and the Music AP came up

  12. listed to music for about an hour.

I think steps 8 thru 12 were what worked, after my exercise with the 2 versions that were a NOGO, I may have confused some steps.

Thanks for your assistance!

Nice to see that it worked! :slight_smile:

Keep in mind that the address only works for the “Volumio” network. The IP address in your Stew network will be different; you can easily check it by going to the Network Settings in Volumio.