Installation Fails with EXT4-fs error

Device: rPi model B
Volumio version: 1.4
Absolute noob to Volumio/linux (hence, I suspect) the installation snafu.

Downloaded zip, extracted image, used Win32 DiskImager to write the disk (NB disk not formatted in anyway before hand, no idea what was on them or their format).
Installation proceeds but halts with:
…switiching to governor performance
303.974627] EXT4-fs (mmcblk0p3):error count: 3
[ 303.985829] EXT4-fs (mmcblk0p3): initial error at 1396987247: mb_free_blocks:1426: block 309248
[ 304.001417] EXT4-fs (mmcblk0p3): last error at 1396987247: ext4_remount:4680
Web client reports volumio.local/ is “not available”.

I have tried:
Downloading the installation zip/img again in case of corruption.
3 different SD cards (one of them known good from my OpenElec rPi). The SD cards in question are 2Gb, 4Gb and 8Gb. Perhaps a larger is required?
Finally, tried another rPi.
Still no joy.
Would be very grateful if anyone can help me get installed. I’m excited to try this marvellous player.

you can try to image the card with the following tool: … -Tool.html. Until now this worked for me. I’m not sure if formatting is really necessary. Sometimes I perform a quick format (just to be sure).

if that does not work try another SD-card reader/writer. My own laptop is having problems with writing cards, so use an external device for this.

Could also be that you need to re-download the image itself. I have used the 1.41 version lately and that installed without any problem.

before you flash the image on the SD card with Win32DiskImager make this:

-> Press the Windows key + R
-> cmd
-> list disk
-> select disk X
(X = the number your SD Card has, look for the size!)
-> clean
-> create partition primary
-> select partition=1
-> active
-> format fs=fat32 quick
-> assign
-> you can close the console now

then you open Win32DiskImager and flash the Image on your SD Card

Attention! You will loose all your files on the selected disk (dont select the wrong disk!!!)

Hello I have the same issue, I followed step-by-step your guide but I can’t fix. Any suggestion?

Guys, there’s a quick start guide here

which says:
Type volumio.local/ on your Device’s browser (has to be connected to the same Network as Volumio)
If you can’t connect to Volumio, just install this or type his IP address ( … rSetup.exe)
Ready! You are now using Volumio’s WebUi. From here you can configure it and control music playback

The errors you’re reporting are not a problem. To connect to volumio.local you must install the file I linked, if you don’t have itunes installed…

Hi Michelangelo, I really appreciate your reply. I thinked it was a problem to solve, since if I type volumio.local/ on any browser I can’t connect to Volumio, even if I type his IP address…

any suggestion?

Ok, let’s investigate…
Does the pi boot correctly? To se this, connect an HDMI monitor and see if the volumio logo appears at the end.
If it doesn’t you’re having problems with the SD card creation process.
Or, if you use the b+ model you should use the 1.41 version

Yes, Volumio logo appears correctly , I have the b+ but the version I downloaded from the site is Volumio1.4PI

Ok. So it boots up correctly.
Next, let’s find out the right IP:
login (root, volumio)

ifconfig -a

You should see this:

The IP is

Is yours output similar to the one above? If yes, what happens when you type the ip in your browser ? (you must be connected to the same network as Volumio)

Sorry, where can I write the code? My keyboard is not working!

In any case, I controlled on (my router) and it seems like the Raspberry is not connected at all (in fact the leds of Ethernet don’t blink)

Ok. So, first check the ethernet cable (if it works, if its correctly plugged etc).
Then use another PSU (I think this could be the problem).
Third, your router may have something wrong.
Are you on B or B+?

The strange thing is that I correctly installed Raspbian and Raspbmc and they worked right (keyboard, mouse and ethernet worked too and I used the same PSU)

I’m on B+

Are you sure you’re using this image