Install Volumio to Internal Hard Drive

I am currently running the X86 version of Volumio from a USB stick on a Netbook. It is possible to install Volumio to the internal hard drive?

Yes, the x86 version calls for an installer, but we have not had the time yet.
Remember, it is still wip.
You can install on your hdd, but not automatically. And you would loose all the data.

This is the way I tested:

  • Format another usb stick wit FAT32, and copy the downloaded x86 image to it.
  • Then boot from your volumio usb stick.
  • Press ctrl-alt-F1, this will open a terminal session
  • Log in with volumio/volumio
  • Type sudo blkid and check the output.
  • You should see /dev/sda, /dev/sdb and /dev/sdc (presuming you only have one disk in your netbook)
    The device with the labels volumioboot, volumioimg and volumiodata is the one you booted from
    The device with the single vfat partition is the stick with the volumio image, assume it is /dev/sdX
    The other device is your netbook’s hdd, assume it is /dev/sdY
  • When sure about the devices, type mkdir usb sudo mount /dev/sdX1 usb cd usb ls -l (should give you the name of the volumio image you've just copied to it) sudo dd if=fullnameofthevolumioimage of=/dev/sdY bs=4M sync poweroff
  • remove the usb sticks, reboot et voilà

Thank you. I’ll try that.

That worked perfectly. Thank you.

I have a netbook with Intel Atom D2700. The system failed to finish boot - similar to the problem reported regarding AMD CPUs.

Would really like to have this resolved.

Worked fine for me on an Asus Aspire One with Intel Atom N455 / 1.66 GHz

We located an issue which prevents a proper initialisation at first start on some x86 machines.
A fix has been prepared and is going to be verified on a machine of which we know it has this problem.
I might call for your help to test it on your machine too, OK?

Sure, thanks

You have a PM

  • Gé -

Yes I do, but I do not want to expose it publicly in a forum, how can I inform you privately?

I meant, you have a personal message, telling you where to download the testimage.
You are right, publishing personal email addresses is not a good idea, I wouldn’t think of asking you :slight_smile:

Just answer here if it worked or not

Send you a PM already.

Just adding my 2 cents: I followed the guide and my system doesn’t boot either.

Error message reads: findfs: unable to resolve ‘LABEL=volumioimg’

Which I can understand, because the internal hdd isn’t found at all. Which is odd because it works on the live CD

Found part of the problem, modules are-generic, ata-piix and pata-sis are not loaded during boot preventing my disk from being instantiated.

Can’t get them to load during boot though. Is that because of the squashfs?

Hi Rob,

thanks for this valuable info, I can check the list of modules I load into initramfs tomorrow.
Not sure if I loaded ata-piix but I know for sure pata-sis is not in.

Edit: They’re both not in, you can’t load them because initramfs does know about them


pata_sis was was added, for some reason I missed it initially.
I thought I also skipped ata_piix, but then I did not have to do anything as it was added as a depending module.

I generated a new image, it still boots on my devices:)
Unfortunately we have a broken “nightly”.
I’m sending you a link as soon as I have something that not just boots but is also something useful :slight_smile:

Looking forward to it!

I also see that I misspelled “ata-generic” in a previous post. That module was also missing, don’t know it’s a dependency or not.

What would the effort be to install the X86 as a script? So, basic Debian install and then just script the environment (perhaps via fancy installer) instead of an image?

not sure why I did not see ata-generic in your post. It should be there though, but I will double-check this tonight.

As to your suggestion, that would be a traditional ‘cookbook’ approach.
Have a look at the build scripts in and you will see that we choose another option for good reasons.
There is the multistrap in ‘’ at the beginning to build the rootfs with a minimum number of packages , followed by a Basic Volumio configuration. This part is platform-specific. The second stage does the system configuration, this is device-specific. Our goal is to have a small zipped starter image of only a few hundred Mb, the smaller the better because of bandwith needed for the download server. With a standard Debian install to start with, we would never ever reach that goal.

ok, now ata_piix, ata_generic and pata_sis are all added and/or loaded.
We might need more modules, tests will show. Link still outstanding…

Just my two cents … I´am not sure if it helpful.

In a virtual environment I would say you try to boot with a wrong controller resp. wrong disk. I had the same message when I tried to boot from a SCSI or SATA disk. The solution for me was a IDE disk type.