I did a custom volumio-os compile and it worked, except 'My Volumio' is missing

I can’t see My Volumio in the left menu, I can’t login, I can’t install plugins because I’m not logged in.

I used raspbian running on a raspberry pi 4b to do the compiling. I followed the instructions from the volumio3-os readme.md GitHub - volumio/volumio3-os

I did:

git clone https://github.com/volumio/volumio3-os.git build

At this point I went and modified recipes/devices/pi.sh to add a newer kernal hash to PI_KERNELS and then set that version in KERNAL_VERSION


./build.sh -b arm
./build.sh -d pi -v 3.378

It created an image, which I burned to my micro SD and then went through the usual volumio setup successfully (hotspot method). Basically everything worked great, but the My Volumio menu and functionality is completely missing.

I’m guessing / hoping it’s an issue I did when compiling rather than that particular module not being compatible with the kernel I used!

I did see in another thread that the My Volumio part is closed source, is that why? Is there anything I can do hear?

I’m doing the custom compiled kernel to get my DSI LCD screen working and it has actually worked, albeit I can’t install the volumio plugin to make it truly work with the GUI etc.


This is normal, “my Volumio” can only be compiled in on the Volumio build server.
This means, your own builds can only have plugins through manual install.

Thank you so much for the quick reply. Okay I will look into manual installs in that case