How to troubleshoot skipping

Hi all!

I’ve got a recently set up Volumio that sometimes gives me skipping problems and I’m trying to pinpoint the source. Since the documentation is mainly concerned with normal operation, I wonder if there are any log files or similar that might assist me with finding the root cause of my issues.

The hardware is a Raspberry Pi B+ with an external dac from MifiMeDIY and an 8 GB SD-card. The software is the standard Volumio image version 1.5

When connected using regular wired networking, it seems to work fine. Using Wifi it mostly works, but I get dropouts and skipping just like the buffers would be depleted. This occurs more frequently when using the wifi for other purposes from other devices.

The wifi info in the Volumio network page shows that I have a 50-60% signal strenght and 20 Mbit/s bandwidth. I’ve increased the buffer sizes to 8192 bytes and 30% respectively - so it seems to me that there is no reason for the buffers to be depleted. The partition size of the SD card is also increased to max as shown in the excellent guide here.

Soo… any hints on how I can go about with my trouble shooting? I would really like to get this thing working with Wifi.

Edit: the music is read from a NAS connected to my home LAN.

Seemes to have solved the problem by replacing the USB wifi interface with a better one.

Nope, still get skipping.

How do I start troubleshooting? Is it any way to see if it’s disk, buffer, CPU issues?

First, I don’t have a solution to the issue you’re facing, but I’m facing the same problem - if we have the same definition of skipping.

I get it when I play higher bitrate files - but not all.

The following file types don’t play:
FLAC - 24bit - 96Khz
ALAC - 24bit - 96Khz
ALAC - 24bit - 192Khz

It generally seems anything above 24bit, 48Khz skips. I am pulling wirelessly from a Synology NAS.

It has worked flawlessly in the past, but I only noticed this since 1.5. However, as I have limited >48Khz material I can’t say 1.5 is exclusively the issue. But only other changes in my environment is the addition of a Roku to the wifi network. However, even when wifi devices are offline, this is a problem. It seems to just not work - there doesn’t appear to be a point at which it partially works.

I too would like to know how to debug via log files or other utilities.

I can’t easily change to wired connection so that is out for debugging.

Make a image of your SD Card. Then try Volumio 1.51 (

If it doesn´t work you can use your image to reflash your sd card.

I’d like to know how to troubleshoot skipping (or dropping out, I guess) audio too.

I have a wirelessly connected Raspberry Pi B with Hifiberry DAC. Music’s on a LG NAS N1T1DD1 in MP3 format.

Is it likely just to be the quality of the wireless connection? That’s what I’m assuming, I’m wondering if there’s anything else I can look at though.




Doesn’t anyone have any ideas about this? I too have an 8K buffer but the dratted thing keeps stopping momentarily at random points while playing! I thought it was the speed of the card, so I bought a class 10 - no joy.

H E L P !