How to mount my PC that contains all my music files

Apologies up front for being so green and unable to figure this out by searching/trial/error…

I cannot get anything to play. :blush:

My Rapberry Pi 2 Model B is ethernet connected to the network along with a Windows 10 PC that contains all my music. The Pi is connected to my AVR via HDMI. Volumio is loaded on the Pi, and when I view my network on the PC I can see the PC and Volumiois on the network . On the Volumio screen I cannot mount my PC as a NAS or anything else, trying several iterations and exhausting each combination. Tried the IP address of the PC (found thru network properties) and also of the router.

Would anyone mind giving some step-by-step guidance to a total newbie?

Last system mount error
Retrying with upper case share name mount error(6): No such device or address Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

Settings are:

Source Name:

fileshare protocol:

IP address:
192.168.1.xx (retrieved my IP address using ipconfig)

remote directory
M:/Music (have tried all upper case, lower case as well)

No username or password entered

Don’t put M:/Music, that’s the local path on the PC.

Just put in the share name.

If your PC with the share is \192.168.1.x\Music just put in Music. You’ll obviously need to make sure you have shared the folder first.

On my server i have a share called Media that contains music, films etc. So i put in Media\Music

Thanks for the tip.

Here’s how the share appears in Windows:
Network Path: \Inspiron-pc\m

So for IP address I’ve tried both 168.192.x and Inspiron-pc
for directory I have m

I now get:
mount error(13): Permission denied Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

Is that share accessible to everyone or does it require a username and password?

At this time it IS accessible to other computers on my Home network with No password

Is that through HomeGroup sharing though or have you actually right clicked the folder and created a share under properties?

Share was created under properties. From another PC on the network I can type \Inspiron-pc\m into a browser and see the directory structure, click, open, etc.

Don’t know if it will help, here are my settings for a folder located at \\Media\Music


Thank You, AlphaPapa…I appreciate your help and advice.

My settings are structured exactly like yours and still no joy. The Share is good on my network. I have tried Volumio and also Runeaudio, both are giving the same errors. There must be something else we are missing…how to further troubleshoot is the question.

Is there any firewall protection or specific machine recognition on your windows share? If you have another linux PC (or even with an android phone or outside of volumio on the pi), try and see if you can connect to the shared drive. Possibly a windows 10 thing?

Sent from my SM-T230NU using Tapatalk