How to get the Spotify plugin working

There are two Spotify plugins for Volumio - Volumio Spotify Connect 2 (by Balbuze and Ashthespy), and Spotify (by Volumio Team). To get the latter “Spotify” plugin working correctly on Volumio you will need to update it as follows.

If you’ve already installed the Spotify plugin remove it, and reboot your system.

SSH into your Volumio system and type the following:

mkdir ./spotify
miniunzip -d ./spotify
cd ./spotify
volumio plugin install
cd ..
rm -Rf spotify*

Now go to Plugins -> Installed Plugins on Volumio and activate the plugin, putting in your Spotify Premium account credentials. On the third line, where it is asking for your Spotify refresh token, click the “i” icon to the right of the text field and you will see a line with the URL Go to that URL in a separate browser window, authenticate with your Spotify Premium account credentials, and cut and paste the Refresh Token into the field on the Volumio Spotify credentials screen. Hit the Save button.


You should be up and running with a greatly enhanced version of Spotify - and it works. :slight_smile:

Thanks to @ma_sk1 for doing the UI extension for the refresh token and the custom install script.

A version of this plugin will be incorporated into the main Volumio distribution in the future.

This does not work for the aug 2019 release. Hangs at downloading plugin.
Fix should be in release, not a bad patch. No money for broken software.

Otherwise I really like Volumio.

Works on my Pi 3 B + pi 7" Touch screen.
If like me you may find it easier to cut and paste the refresh token into /data/configuration/music_service/spop/config.json as I am unsure how to open another web browser from within Volumio.

Works on experimental build for RPI4.


Works for Volumio 2.599 ( Aug/19) and Spotify 1.3.5

It was quite easy fix after you get SSH enabled.

Big Thank you, I finally got my playlists and albums back!


since the new Plugin I am having troubles with the Music Playback.
Spotify basically works, but after a few Hours (sometimes Days), Volumio keeps stopping to play music.
Pressing “skip track” helps, but as soon as it happens once, the Error happens every few Tracks.
Rebooting helps most of the time, sometimes I have to switch to a different Source for a Day or two,
until Spotify works better again.


the solution worked for me, thanks a lot.

I would also say that not updating the official pluggin is not nice from volumio team (only needing to copy your solution should not be that difficult)

It is nice to see you have the code published in github.

It is not that easy to understand the access to, neither why it’s not at least unders https to make is safer and feel more secure

So, I don’t know who owns, and all the information is free for the owner as well as not encripted on the net.

Please don’t missunderstand me, I¡m so happy you found how to make it work, but I would like to see volumio adding the solution and providing the tools in their site and with their ssl certificate.


Hi there, glad the patch worked for you. I am currently paying for the AWS EC2 server myself until the solution becomes part of Volumio, and setting up the site with an SSL cert and then configuring it is beyond what I have time to do right now. I am confident the Volumio team will incorporate the patched plugin into the main branch of Volumio soon.

In the mean time, hope you enjoy the music!

Hi everyone, I’ve followed every steps but can’t make it work.
The music selection does not show any spotify tab :frowning:

Any ideas on how to make it work?

I’m on the last volumio build on Rpi3 B+


Can you share your log file: /var/log/volumio.log.

Hi @skikirkwood, here is my log file

2019-09-21T16:57:34.134Z - info: Updating MyVolumio device info
2019-09-21T16:57:34.136Z - info: CoreCommandRouter::executeOnPlugin: system , getConfigParam
2019-09-21T16:57:34.138Z - info: CoreCommandRouter::executeOnPlugin: system , getConfigParam
2019-09-21T16:57:34.140Z - info: CoreCommandRouter::executeOnPlugin: system , getConfigParam
2019-09-21T16:57:34.409Z - info: Connecting to daemon
2019-09-21T16:57:34.435Z - info: SPOP command error:
2019-09-21T16:57:34.440Z - info:  message=connect ECONNREFUSED, stack=Error: connect ECONNREFUSED
 at Object._errnoException (util.js:1022:11)
 at _exceptionWithHostPort (util.js:1044:20)
 at TCPConnectWrap.afterConnect [as oncomplete] (net.js:1198:14), code=ECONNREFUSED, errno=ECONNREFUSED, syscall=connect, address=, port=6602
2019-09-21T16:57:34.443Z - info: SPOP status error:
2019-09-21T16:57:34.447Z - info:  message=connect ECONNREFUSED, stack=Error: connect ECONNREFUSED
 at Object._errnoException (util.js:1022:11)
 at _exceptionWithHostPort (util.js:1044:20)
 at TCPConnectWrap.afterConnect [as oncomplete] (net.js:1198:14), code=ECONNREFUSED, errno=ECONNREFUSED, syscall=connect, address=, port=6602
2019-09-21T16:57:34.675Z - info: New Spotify access token = BQAij1WTzItLQN-zcaadCxQCxhsqMOf7wZWPd-puPwiVOd7v79AuuObHM2OY7yqMZCBiokFpcMLCVxwjhgA7oZmyzUAdSsH4EghpjJVsnhA6Xotg0BQV7GA3wLMtQWRtZXR_a29XUUxyR-yqO9Usd7trMVpubBqrFbq9_rfPD2v8gpQczuqQkhUYcAqMQA  
2019-09-21T16:57:34.678Z - info: Spotify credentials grant success - running version from March 24, 
2019-09-21T16:57:35.148Z - info: CoreCommandRouter::volumioGetQueue

I to had issues with not seeing playlists etc and have just tried the solution in the first post and all seem to be working. Thank you and fingers crossed :slight_smile:

That’s a bummer. For some reason Volumio is now able to make the connection to the demon that actually does the audio rendering for Spotify. I’ve seen this before on rare occasions but have no idea what’s behind it, and I’ve never touched that area of the code base. Sorry I can’t help.


Same thing here, Raspberry Pi 3 B+, tried 2.599, 2.609 and 2.618, all fresh installs, activate SSH, your instructions, plugin installed, activate it with a family account and the refresh token, press “SAVE”, nothing happens, and go to library and Spotify button is not there… Reboot. etc. nothing helps…

My log:

2019-09-26T19:56:11.131Z - info: ------------------------------------------- 2019-09-26T19:56:11.134Z - info: ----- Volumio2 ---- 2019-09-26T19:56:11.134Z - info: ------------------------------------------- 2019-09-26T19:56:11.134Z - info: ----- System startup ---- 2019-09-26T19:56:11.134Z - info: ------------------------------------------- 2019-09-26T19:56:11.216Z - info: MYVOLUMIO Environment detected 2019-09-26T19:56:11.329Z - info: Plugin folders cleanup 2019-09-26T19:56:11.329Z - info: Scanning into folder /volumio/app/plugins/ 2019-09-26T19:56:11.330Z - info: Scanning category audio_interface 2019-09-26T19:56:11.331Z - info: Scanning category miscellanea 2019-09-26T19:56:11.332Z - info: Scanning category music_service 2019-09-26T19:56:11.333Z - info: Scanning category plugins.json 2019-09-26T19:56:11.333Z - info: Scanning category system_controller 2019-09-26T19:56:11.334Z - info: Scanning category user_interface 2019-09-26T19:56:11.335Z - info: Scanning into folder /data/plugins/ 2019-09-26T19:56:11.336Z - info: Scanning category music_service 2019-09-26T19:56:11.336Z - info: Plugin folders cleanup completed 2019-09-26T19:56:11.338Z - info: ------------------------------------------- 2019-09-26T19:56:11.338Z - info: ----- Core plugins startup ---- 2019-09-26T19:56:11.338Z - info: ------------------------------------------- 2019-09-26T19:56:11.340Z - info: Loading plugins from folder /volumio/app/plugins/ 2019-09-26T19:56:11.343Z - info: Adding plugin upnp to MyMusic Plugins 2019-09-26T19:56:11.345Z - info: Adding plugin airplay_emulation to MyMusic Plugins 2019-09-26T19:56:11.346Z - info: Adding plugin upnp_browser to MyMusic Plugins 2019-09-26T19:56:11.348Z - info: Loading plugins from folder /data/plugins/ 2019-09-26T19:56:11.351Z - info: Loading plugin "system"... 2019-09-26T19:56:11.378Z - info: Loading plugin "appearance"... 2019-09-26T19:56:12.672Z - info: Loading plugin "network"... 2019-09-26T19:56:13.210Z - info: Loading plugin "services"... 2019-09-26T19:56:13.215Z - info: Loading plugin "alsa_controller"... 2019-09-26T19:56:13.329Z - info: Loading plugin "wizard"... 2019-09-26T19:56:13.345Z - info: Loading plugin "volumio_command_line_client"... 2019-09-26T19:56:13.354Z - info: CoreCommandRouter::executeOnPlugin: alsa_controller , getConfigParam 2019-09-26T19:56:13.355Z - info: CoreCommandRouter::executeOnPlugin: alsa_controller , getConfigParam 2019-09-26T19:56:13.356Z - info: CoreCommandRouter::executeOnPlugin: alsa_controller , getConfigParam 2019-09-26T19:56:13.356Z - info: CoreCommandRouter::executeOnPlugin: alsa_controller , getConfigParam 2019-09-26T19:56:13.384Z - info: Loading plugin "upnp"... 2019-09-26T19:56:13.392Z - info: [1569527773392] Starting Upmpd Daemon 2019-09-26T19:56:13.395Z - info: CoreCommandRouter::executeOnPlugin: system , registerCallback 2019-09-26T19:56:13.397Z - info: Loading plugin "my_music"... 2019-09-26T19:56:13.408Z - info: Loading plugin "mpd"... 2019-09-26T19:56:13.908Z - info: Loading plugin "upnp_browser"... 2019-09-26T19:56:14.986Z - info: Loading plugin "networkfs"... 2019-09-26T19:56:15.428Z - info: CoreCommandRouter::executeOnPlugin: system , registerCallback 2019-09-26T19:56:15.429Z - info: Loading plugin "alarm-clock"... 2019-09-26T19:56:15.653Z - info: Loading plugin "airplay_emulation"... 2019-09-26T19:56:15.678Z - info: Starting Shairport Sync 2019-09-26T19:56:15.679Z - info: Loading plugin "last_100"... 2019-09-26T19:56:15.686Z - info: Loading plugin "webradio"... 2019-09-26T19:56:15.796Z - info: Loading plugin "i2s_dacs"... 2019-09-26T19:56:15.810Z - info: I2S DAC not set, start Auto-detection 2019-09-26T19:56:15.827Z - info: Loading plugin "volumiodiscovery"... 2019-09-26T19:56:15.894Z - info: Applying required configuration parameters for plugin volumiodiscovery 2019-09-26T19:56:15.924Z - info: CoreCommandRouter::executeOnPlugin: system , registerCallback 2019-09-26T19:56:15.925Z - info: Loading plugin "outputs"... 2019-09-26T19:56:15.933Z - info: Loading plugin "albumart"... 2019-09-26T19:56:15.957Z - info: Plugin example_plugin is not enabled 2019-09-26T19:56:15.958Z - info: Loading plugin "inputs"... 2019-09-26T19:56:15.968Z - info: Loading plugin "updater_comm"... 2019-09-26T19:56:16.194Z - info: Plugin mpdemulation is not enabled 2019-09-26T19:56:16.196Z - info: Loading plugin "rest_api"... 2019-09-26T19:56:16.237Z - info: Loading plugin "websocket"... 2019-09-26T19:56:16.269Z - info: Loading plugin "spop"... 2019-09-26T19:56:17.417Z - info: Applying required configuration parameters for plugin spop 2019-09-26T19:56:17.434Z - info: ___________ START PLUGINS ___________ 2019-09-26T19:56:17.441Z - info: CoreCommandRouter::executeOnPlugin: mpd , getConfigParam 2019-09-26T19:56:17.442Z - info: CoreCommandRouter::volumioAddToBrowseSources[object Object] 2019-09-26T19:56:17.444Z - info: [1569527777443] CoreMusicLibrary::Adding element Media Servers 2019-09-26T19:56:17.445Z - info: CoreCommandRouter::executeOnPlugin: my_music , getDisabledSources 2019-09-26T19:56:17.523Z - info: Could not detect Primo: Error: Command failed: aplay -l | grep es90x8q2m-dac-dai-0 2019-09-26T19:56:17.556Z - info: Could not detect Primo: Error: Command failed: aplay -l | grep es90x8q2m-dac-dai-0 2019-09-26T19:56:17.558Z - info: CoreCommandRouter::volumioAddToBrowseSources[object Object] 2019-09-26T19:56:17.559Z - info: [1569527777558] CoreMusicLibrary::Adding element Last_100 2019-09-26T19:56:17.559Z - info: CoreCommandRouter::executeOnPlugin: my_music , getDisabledSources 2019-09-26T19:56:17.564Z - info: CoreCommandRouter::volumioAddToBrowseSources[object Object] 2019-09-26T19:56:17.565Z - info: [1569527777564] CoreMusicLibrary::Adding element Webradio 2019-09-26T19:56:17.565Z - info: CoreCommandRouter::executeOnPlugin: my_music , getDisabledSources 2019-09-26T19:56:17.571Z - info: CoreCommandRouter::executeOnPlugin: system , getSystemVersion 2019-09-26T19:56:17.601Z - info: ------------------------------------------- 2019-09-26T19:56:17.601Z - info: ----- MyVolumio plugins startup ---- 2019-09-26T19:56:17.602Z - info: ------------------------------------------- 2019-09-26T19:56:17.604Z - info: Loading plugins from folder /myvolumio/plugins 2019-09-26T19:56:17.699Z - info: Loading plugins from folder /data/myvolumio/plugins 2019-09-26T19:56:17.702Z - info: Loading plugin "cd_controller"... 2019-09-26T19:56:17.750Z - info: Loading plugin "streaming_services"... 2019-09-26T19:56:18.118Z - info: Loading plugin "my_volumio"... 2019-09-26T19:56:18.767Z - info: Adding CD REST API Endpoints 2019-09-26T19:56:18.769Z - info: Adding detectCD REST Endpoint for plugin: music_service/cd_controller 2019-09-26T19:56:18.769Z - info: Adding cdRemove REST Endpoint for plugin: music_service/cd_controller 2019-09-26T19:56:18.770Z - info: Adding cdPostScan REST Endpoint for plugin: music_service/cd_controller 2019-09-26T19:56:18.770Z - info: Adding cdPostRip REST Endpoint for plugin: music_service/cd_controller 2019-09-26T19:56:18.771Z - info: Detecting CD presence 2019-09-26T19:56:18.772Z - info: Streaming services startup 2019-09-26T19:56:18.777Z - info: Starting Streaming Daemon 2019-09-26T19:56:18.790Z - info: CoreCommandRouter::executeOnPlugin: system , getConfigParam 2019-09-26T19:56:18.791Z - info: CoreCommandRouter::executeOnPlugin: system , getConfigParam 2019-09-26T19:56:18.794Z - info: Starting MyVolumio Remote Streaming Endpoints 2019-09-26T19:56:18.835Z - info: Loading i18n strings for locale es 2019-09-26T19:56:18.844Z - info: CoreCommandRouter::executeOnPlugin: my_music , getDisabledSources 2019-09-26T19:56:18.873Z - info: CoreCommandRouter::executeOnPlugin: mpd , getConfigParam 2019-09-26T19:56:18.875Z - info: CoreCommandRouter::initPlayerControls 2019-09-26T19:56:18.885Z - info: CoreCommandRouter::executeOnPlugin: alsa_controller , getConfigParam 2019-09-26T19:56:18.885Z - info: CoreCommandRouter::executeOnPlugin: alsa_controller , getAlsaCards 2019-09-26T19:56:18.911Z - info: CoreCommandRouter::executeOnPlugin: alsa_controller , getConfigParam 2019-09-26T19:56:18.911Z - info: CoreCommandRouter::executeOnPlugin: alsa_controller , getConfigParam 2019-09-26T19:56:18.912Z - info: CoreCommandRouter::executeOnPlugin: alsa_controller , getConfigParam 2019-09-26T19:56:18.912Z - info: CoreCommandRouter::executeOnPlugin: alsa_controller , getConfigParam 2019-09-26T19:56:18.913Z - info: CoreCommandRouter::executeOnPlugin: alsa_controller , getConfigParam 2019-09-26T19:56:18.922Z - info: CoreCommandRouter::executeOnPlugin: mpd , getConfigParam 2019-09-26T19:56:18.928Z - info: BOOT COMPLETED 2019-09-26T19:56:18.929Z - info: CoreCommandRouter::executeOnPlugin: system , getConfigParam 2019-09-26T19:56:44.193Z - info: CoreCommandRouter::Close All Modals sent 2019-09-26T19:56:44.194Z - info: CoreCommandRouter::Close All Modals sent 2019-09-26T19:56:44.274Z - info: MyVolumio not started 2019-09-26T19:56:44.275Z - info: Initializing device activation check 2019-09-26T19:56:44.278Z - info: CoreStateMachine::resetVolumioState 2019-09-26T19:56:44.278Z - info: CoreStateMachine::getcurrentVolume 2019-09-26T19:56:44.279Z - info: CoreCommandRouter::volumioRetrievevolume 2019-09-26T19:56:44.434Z - info: Cannot read play queue from file 2019-09-26T19:56:44.703Z - info: Setting Device type: Raspberry PI 2019-09-26T19:56:44.705Z - info: SpopD Daemon Started 2019-09-26T19:56:44.724Z - info: MPD running with PID590 ,establishing connection 2019-09-26T19:56:44.856Z - info: VolumeController:: Volume=40 Mute =false 2019-09-26T19:56:44.858Z - info: CoreStateMachine::pushState 2019-09-26T19:56:44.860Z - info: CoreStateMachine::getState 2019-09-26T19:56:44.861Z - info: CorePlayQueue::getTrack 0 2019-09-26T19:56:44.863Z - info: CoreCommandRouter::volumioPushState 2019-09-26T19:56:44.863Z - info: CoreCommandRouter::executeOnPlugin: volumiodiscovery , saveDeviceInfo 2019-09-26T19:56:44.875Z - info: Volumio called home 2019-09-26T19:56:44.941Z - info: CoreCommandRouter::executeOnPlugin: system , getConfigParam 2019-09-26T19:56:44.972Z - info: 2019-09-26T19:56:44.979Z - info: message= [50@0] {} No such directory, stack=Error: [50@0] {} No such directory at MpdClient.receive (/volumio/app/plugins/music_service/mpd/lib/mpd.js:63:14) at Socket.<anonymous> (/volumio/app/plugins/music_service/mpd/lib/mpd.js:43:10) at emitOne (events.js:116:13) at Socket.emit (events.js:211:7) at addChunk (_stream_readable.js:263:12) at readableAddChunk (_stream_readable.js:246:13) at Socket.Readable.push (_stream_readable.js:208:10) at Pipe.onread (net.js:607:20) 2019-09-26T19:56:45.156Z - info: CoreStateMachine::setRepeat null single undefined 2019-09-26T19:56:45.158Z - info: CoreStateMachine::pushState 2019-09-26T19:56:45.159Z - info: CoreStateMachine::getState 2019-09-26T19:56:45.160Z - info: CorePlayQueue::getTrack 0 2019-09-26T19:56:45.161Z - info: CoreCommandRouter::volumioPushState 2019-09-26T19:56:45.161Z - info: CoreCommandRouter::executeOnPlugin: volumiodiscovery , saveDeviceInfo 2019-09-26T19:56:45.167Z - info: CoreStateMachine::setRandom null 2019-09-26T19:56:45.168Z - info: CoreStateMachine::pushState 2019-09-26T19:56:45.168Z - info: CoreStateMachine::getState 2019-09-26T19:56:45.169Z - info: CorePlayQueue::getTrack 0 2019-09-26T19:56:45.170Z - info: CoreCommandRouter::volumioPushState 2019-09-26T19:56:45.171Z - info: CoreCommandRouter::executeOnPlugin: volumiodiscovery , saveDeviceInfo 2019-09-26T19:56:45.247Z - info: CoreCommandRouter::executeOnPlugin: alsa_controller , checkAudioDeviceAvailable 2019-09-26T19:56:45.272Z - info: CoreCommandRouter::executeOnPlugin: system , versionChangeDetect 2019-09-26T19:56:45.327Z - info: Shairport-Sync Started 2019-09-26T19:56:45.331Z - info: Shairport-Sync Started 2019-09-26T19:56:45.332Z - info: Upmpdcli Daemon Started 2019-09-26T19:56:45.346Z - info: CoreCommandRouter::volumioGetState 2019-09-26T19:56:45.346Z - info: CoreStateMachine::getState 2019-09-26T19:56:45.347Z - info: CorePlayQueue::getTrack 0 2019-09-26T19:56:46.357Z - info: CoreCommandRouter::volumioGetVisibleSources 2019-09-26T19:56:46.359Z - info: CoreCommandRouter::executeOnPlugin: my_music , getDisabledSources 2019-09-26T19:56:46.373Z - info: CoreCommandRouter::volumioGetState 2019-09-26T19:56:46.374Z - info: CoreStateMachine::getState 2019-09-26T19:56:46.376Z - info: CorePlayQueue::getTrack 0 2019-09-26T19:56:46.382Z - info: CoreCommandRouter::executeOnPlugin: multiroom , getMultiroom 2019-09-26T19:56:46.384Z - info: Listing playlists 2019-09-26T19:56:46.390Z - info: CoreCommandRouter::volumioGetQueue 2019-09-26T19:56:46.392Z - info: CoreStateMachine::getQueue 2019-09-26T19:56:46.394Z - info: CorePlayQueue::getQueue 2019-09-26T19:56:47.439Z - info: Fetching Streaming Services browse cache 2019-09-26T19:56:47.539Z - info: CoreCommandRouter::volumioRemoveToBrowseSourcesTIDAL 2019-09-26T19:56:47.540Z - info: CoreCommandRouter::executeOnPlugin: my_music , getDisabledSources 2019-09-26T19:56:47.552Z - info: CoreCommandRouter::volumioRemoveToBrowseSourcesQOBUZ 2019-09-26T19:56:47.553Z - info: CoreCommandRouter::executeOnPlugin: my_music , getDisabledSources 2019-09-26T19:56:49.707Z - info: Connecting to daemon 2019-09-26T19:56:49.730Z - info: SPOP command error: 2019-09-26T19:56:49.731Z - info: message=connect ECONNREFUSED, stack=Error: connect ECONNREFUSED at Object._errnoException (util.js:1022:11) at _exceptionWithHostPort (util.js:1044:20) at TCPConnectWrap.afterConnect [as oncomplete] (net.js:1198:14), code=ECONNREFUSED, errno=ECONNREFUSED, syscall=connect, address=, port=6602 2019-09-26T19:56:49.734Z - info: SPOP status error: 2019-09-26T19:56:49.734Z - info: message=connect ECONNREFUSED, stack=Error: connect ECONNREFUSED at Object._errnoException (util.js:1022:11) at _exceptionWithHostPort (util.js:1044:20) at TCPConnectWrap.afterConnect [as oncomplete] (net.js:1198:14), code=ECONNREFUSED, errno=ECONNREFUSED, syscall=connect, address=, port=6602 2019-09-26T19:56:49.920Z - info: New Spotify access token = BQD0v50ZZz2y4wTzyhk0kZw5r7nAHZdqIFJ7ULdC65MPiT1JpNrir465PsXinMP4Yhh1oZT1Q15vlKq-2ScSaAPDYfu4h_-6jd-wmOnrgHz12lnhu7lF57_YQqTlKJC3rx1VvneFMbl4ao_NEVQ2bHpu3FPFRMUJHwzpCQ1VoRS53hDLqrriA40k9-3SXnQ_O_oZYNdq4a6k9UWvYJoJpA 2019-09-26T19:56:49.922Z - info: Spotify credentials grant success - running version from March 24, 2019

I have a couple of 3B+ running Volumio may or april versions and your former patch for the spop plugin, with the token handwritten to the code and they work OK.

It’s a pity that all your work with the refurbished plugin is useless with the new versions.

Yep, that’s the same connection error as the previous poster. Sorry guys, but this is beyond my debugging capabilities. We need some help from the core Volumio team on this, and hopefully they can get a new version of the plugin out without the need for going to an AWS EC2 server and do the Oauth authentication.

I cannot thank you enough for this. This is working for me, on Volumio 2.619 on RPI.

Keep up the great work :smiley:

For everyone who is getting this message, I have found a fix. If you login using Facebook, it will not work and you will get the ECONNREFUSED What you have to do is create a device password in spotify. Go to this page and set a device password if you have not done so. It will send you a link to your email that you click to reset the password. Then in the volumio plugin you have to enter your device username and device password.

When getting the refresh token, go the the url given and login with Facebook like you normally would and use that refresh code.


When I follow the link you post I land in the account page of Spotify, no device password page for me (premium family account), don’t know for normal Premium accounts…

All I have in the web is a “connected devices” link and there I can see all the devices i gave access to this account and could remove them, but nothing more.

Anyway thank you for the info and, maybe, your info could guide us to resolve this as I can see an user with RPI and last version got the spotify plugin working, if would be awesome if he could share with us how he did it and what RPI model is using.

Awesome that you figured this out and thanks for posting!

Same error for me as the users above. I am on a fresh install as of today, 2.632.