How to disable Audio Outputs?


Using a Raspberry 4 (CM4).

I am trying to build a new Audio Player and I need to only have the Output Devices which really works on the hardware. In the General Playback Options, under Audio Output, in the Drop Down List “Output Device”, I have 2 devices which need to be removed: “HDMI Out” and “Headphones”.

How can I remove from the list those 2 devices? Which configuration files must be updated?
I also need these changes to be kept when Volumio is updated.

Thank you very much for your help!


No Clue? Do I need to provide more information ?
Thank you!

Not sure if people will answer, as it will involve breaking vanilla coding. Just configure the desired output and leave it as is.

I just don’t get the interest. Only the selected output is in use and in the Alsa pipeline.


Ah ok.

1/Those 2 additional outputs do not exist, this is not good from a user experience standpoint to have them

2/I have a problem where when switching between various song quickly where Volumio loose the output resetting to one of those 2 invalid outputs then it is needed to get back to the setting, this is very bad for the user.

How should I address these problems from your standpoint?

Thank you very much


Hi lelsteph,

I do have lots of different RaspberryPIs and different DACs and never encountered such a behaviour.
Maybe you can try a fresh setup on another SD card to see if it that still happens.

What output device are you using ?
In case you use USB it may be necessary that the device is powered before you start Volumio. -removing the entries for HDMI and Phones won’t help also in that situation i guess.


Thank you.
I flashed several time clean volumio.
This happens when correctly playing song and just switching between songs. It does not happen when using music from the local network (a NAS) or a USB key. It happens when using internet music only.

Please also consider my points on the user experience with invalid outputs.

So can I remove them by some means?

Thank you!