How to compile MPD for volumio

Hi all,

I’ve been trying to get a newer version of MPD running on my volumio installations (both 1.55 and 2.0).
However it seems that if I use the script found in the build section: …
Or any other build MPD script I run into some problems.

Since 1.55 is no longer supported I will focus on 2.0. I was able to compile a newer version (0.19.17), but I needed to update the mpd.conf:

  1. The bind_to_address value cannot be ‘any’ but must be set to
  2. The samplerate_converter value ‘soxr very high’ is no longer recognized

The script I use to compile MPD is:



echo ‘Installing Required Packages’
apt-get -y install devscripts dh-make
echo ‘Installing Dependencies’
apt-get -y build-dep mpd
echo ‘Getting MPD source tarball’
echo ‘Unpacking Source’
tar xvf *.xz
cd mpd-0.19.17

echo ‘Debianizing Source’
export DEBFULLNAME=“Michelangelo Guarise”
dh_make -f …/mpd-0.19.17.tar.xz -s
cp -r …/debian mpd-0.19.17
echo ‘Compiling into Deb Package’
debuild binary

I perform the following steps:

  1. I create a temp direction within the volumio home dir
  2. I copy the debian directory (from the git) and the build script file to the temp dir
  3. I stop MPD > “sudo /etc/init.d/mpd stop”
  4. After execution I use “dpkg -i mpd_0.19.17-1_armhf.deb” to install the new version
  5. I start MPD > “sudo /etc/init.d/mpd start”

Note that if I edit the mpd.conf file I am able to start MPD, it doesn’t seem to work with volumio though.

Anyone have any thoughts on the matter? :slight_smile:

I am especially interested in (at least) version 13:

ver 0.19.13 (2016/02/23)

  • tags
    • aiff, riff: fix ID3 chunk padding
  • decoder
    • ffmpeg: support the TAK codec
  • fix disappearing duration of remote songs during playback
  • initialize supplementary groups with glibc 2.19+

ver 0.19.12 (2015/12/15)

  • fix assertion failure on malformed UTF-8 tag
  • fix build failure on non-Linux systems
  • fix LimitRTTIME in systemd unit file

I am compiling the new version as we speak, it’s a little tricky because the last time it ended up not being very stable…

That is super news! Thanks! I’ve tried updating myself but I am missing 90% of the plugins :blush: I could test it for you however, I have spare pi’s for that purpose (with DAC). :slight_smile:

I either need a deb-file or noob proof instructions :blush:

Can I be of any assistance in this matter? I have Pi’s lying around able to build/compile and I can test the built debs on other Pi’s if need be. :slight_smile:

I think I have the correct package now… but it doesn’t install because of the following error:

volumio@volumio:~$ sudo dpkg -i mpd-volumio_0.19.17-1_armhf.deb [sudo] password for volumio: (Reading database ... 18051 files and directories currently installed.) Preparing to unpack mpd-volumio_0.19.17-1_armhf.deb ... Unpacking mpd-volumio (0.19.17-1) ... dpkg: error processing archive mpd-volumio_0.19.17-1_armhf.deb (--install): trying to overwrite '/usr/share/doc/mpd/AUTHORS', which is also in package mpd 0.19.9-2 dpkg-deb: error: subprocess paste was killed by signal (Broken pipe) Errors were encountered while processing: mpd-volumio_0.19.17-1_armhf.deb

So I removed the package mpd

sudo dpkg -P mpd

After that I could install mpd using “sudo dpkg -i mpd-volumio_0.19.17-1_armhf.deb”.
But obviously the config was gone because of the dpkg -P command, so I copied that before I updated.

After installation the ‘mpd -V’ command gives me the correct values, I guess. :unamused: But I cannot add new mounts through the volumio app. Will try if the already made connections persist or not. Maybe someone can point me in the right direction? :blush:

The package I compiled is attached, note: it has been compiled on a rPi2B running version 979 use it at your own risk. (241 KB)

Update: the shares do not persist, it seems as if mpd has no rights to the share(s).