How to boot Volumio from HDD/SSD on Cubietruck? [Solved]


Is it possible to boot Volumio from HDD/SSD?


I do not have a Cubie board so these are just guesses.
It might be possible to have the ROOT partition on the hard-disk but I guess the boot partition should remain on th SD card (or NAND as there is one on the Cubie).
Just edit the cmdline.txt file and change “root=/dev/mmcblk0p3” to “root=/dev/sda1” (or whatever partition you have created).
Make an EXT4 partition on your hard-drive, format it and copy the files from /dev/mmcblk0p3 to this partition (do it as root and preserve owners/permissions).

Thank You for the answer.
I tried to do this, but unfortunately doesn’t work. Volumio starts from SD card. I have no cmdline.txt file on system , I changed /boot/uEnv.ct file


I found solution, how to boot Volumio 1.4 from HDD/SSD.
First we have to boot Volumio from uSD card, next we have to format partition on HDD

sudo mkfs.ext4 /dev/sda1

After that we have to copy file system from uSD to HDD

sudo dd if=/dev/mmcblk0p1 of=/dev/sda1 bs=1024

Next check sda1 for errros:

e2fsck -f -y /dev/sda1

If You have many errors, it means that copying goes wrong, operation of copying file system must be repeated once again:

sudo dd if=/dev/mmcblk0p1 of=/dev/sda1 bs=1024

Second time should be O.K. but check your sda1 for errors once again (possible small amount of errors).

e2fsck -f -y /dev/sda1

resize partion

resize2fs /dev/sda1

Next edit uEnv.ct file

sudo nano /boot/uEnv.ct

change line from

root=/dev/mmcblk0p1 rootwait
[/code] to [code]
root=/dev/sda1  rootwait

and reboot
I hope it helps.