How do I get ssh to work with Volumio 2 please?


Volumio 2 web interface stopped working for me for several days, despite repeated reboots etc., although I was still able to ssh into the device (Raspberry Pi 2 with IQAudioPlus DAC with music stored on a local Samsung USB HDD), so it was still alive as a Linux system. I also tried stopping and restarting and updating the mpd service - tried things like apt-get --reinstall mpd and sudo /etc/init.d/mpd restart as recommended in different posts here. Nothing worked.

So today I Etcher-ed a brand new Volumio using the latest version onto a fresh SD card. That loaded up fine, found the music on the HDD and now plays, except the music gets interrupted every few seconds as the USB drive is not getting enough current - you can hear the HDD heads parking every few seconds. So, I need to use ssh to edit the configuration file to change the max current setting for the USB drives from 0.6A to 1.2A (i.e. add max_usb_current=1 to /boot/config.txt). This is what I did before and it sorted the HDD problem out.

Using ssh volumio@volumio worked before, but now I get a timeout when I use this so I can’t access the Raspberry Pi to change the settings. Has the default volumio username and password (i.e. volumio and volumio) changed recently? The FAQs say it is still going to be volumio@volumio as the device and user with the same password volumio by default, so it doesn’t seem to have changed?

I searched online and others have similar problems, and there are comments about ssh not working in one version of volumio 2. Someone else says “you may need to delete the old SSH key out of your systems”, and if I had the first clue how to do that, I would try it! Would that be in /etc/ssh/ssh_config on the MacBookPro I am trying to use ssh from?

Thanks very much if anyone here can give me a simple way to diagnose what has changed and why ssh no longer appears to work as it did before (or any other remote way to update the Raspberry Pi’s max_usb_current setting) .

So, today I have solved my web interface problem, but have created new one in its place that still stops the music from playing:-( Many thanks.

I fixed this myself by cheating - I bought a wired keyboard from a charity shop and plugged into a TV and made the edits. So the max current configuration is now fixed.

It is handy to be able to use ssh to access the device, so it would be interesting to know what I did in installing the latest volumio version that stopped ssh working, and stopped the picommand iPhone app being able to see the device. I can ping the pi using the fing iPhone app, and get sensible ping responses, so it is there and responsive.


Could it be related to this?

Luckily we build our Raspbian image from scratch :slight_smile: , but we did have an issue with ssh a while ago.
@backnotes: which version where you using? You may want to test this version

– Gé –

It’s still an issue with SSH (2.063) ! haven’t worked for me after ver 2.043

Current version 2.041 (Pi) works fine

I had twice this problem after updating from 2.041 to 2.06. A fresh install is ok…

hi @balbuze and thanks
After a fresh install of 2.063, ssh works again !

Thanks for all these helpful suggestions.

I am using Version 2.041 downloaded from here I had assumed this was the current version for the Raspberry Pi?

Above is a suggestion to try a later version via this link 2017-02-06-volumio-2.063 but whenever I click this (I have tried several times over several days) I get a 404 Not Found Error.

Can someone tell me where to access the later versions (2.06 etc.) described above that may provide a fix for the ssh issue?

Many thanks for everyone’s help!

Is there a reason that has not been announced publicly, is not available from the Downloads page and is not available as an OTA update (which insists that 2.041 is the “latest version”)?

Is it, perhaps, a semi-public beta, rather than a release version?

Yes, we’re not ready yet with a release-ready version…

Very happy to report that V2.063 has fixed the ssh problem I was experiencing.

It has also fixed some other problems I had not asked about after moving from 1.55 to 2.:

  • radio stations work again
  • I am able to see and catalogue my NAS again - I had blamed changes to the home network, but this now works
  • the Spotify plugin is available again - this was there in 1.55 but seemed to be missing or need an extra step I never worked out to install in v2

So, all my problems seem to have been solved for now. I look forward to the official release but everything seems to be headed in the right direction as far as I can see.

Thank you very much for everyone’s help and patience and for all the hard work that goes into all this.