How do I access my music?

Hi, I hope someone can guide me.

I have a Raspberry Pi c/w HiFiBerry Digi running Volumio 1.1. I have accesses the web GUI from my iPad but I don’t understand how I’m supposed to configure to access my music files.

The music is stored on an external HDD connected to my iMac which is on the same network as the Pi. I don’t suppose it’s difficult, but I’ve not managed to work it out.

Help much appreciated.

I’m still having trouble mounting the shares. This is what I have entered in the web GUI:

Source name: XLD (being one of the music holding folders on the Drobo)
File share protocol: SMB/CIFS (I don’t know whether or not this is correct, but the iMac says it connected to at smb://
IP address: (being the IP address of the iMac)
Remote directory: Drobo/XLD (Drobo being the name of the external HDD connected to the iMac)
User name: myusername
Password: mypassword

Having saved this the GUI tells me that it is updating the database, but it also has a little red cross and states:

Last system mount error
mount: Operation not supported

Any ideas?

In the absence of any help from here, is there anywhere else you can recommend I go?

I don’t know if it might be useful to try something like RuneAudio, to see if you can get everything to work there? That’s a similar distribution to Volumio, and shares a common parent distribution in Raspyfi.

Thanks for the suggestion. I’ve got wired AirPlay working brilliantly, so I can push the music to it, but I can’t figure out the configuration to be able to pull it.

I did try Squeezeplug, but had to use Logitech Media Server installed on the Mac rather than on the Pi. SQ was not good.

Why did you have to install LMS on the Mac? I’ve installed SqueezePlug myself on the Pi, and it worked fine, with LMS and Squeezelite installed on the Pi.

I’m afraid I can’t offer any advice on the NAS issue as I don’t use a NAS. I have most of my music on a 64GB SD card, and the overflow on a 64GB USB stick. It works fine.

I suggested trying RuneAudio as I think I’ve seen posts from people who have successfully got their NAS connected under RuneAudio, when they couldn’t under Volumio. Not sure why that should be, as the people on both projects used to work together, although I think Volumio is based on Raspian, whereas RuneAudio uses Arch Linux.

I assume the reason I had to use LMS on the Mac rather than on the Pi is the same issue I’m having accessing music on the Mac from the Pi. I don’t have a NAS as such; it’s all on an HDD connected directly to the Mac.

So its attached to your Mac rather than to a router? I wonder if that is the issue? Could you not attach the HDD to your router? Or if it is a USB HDD directly to the Pi?

I don’t believe I could. It isn’t a NAS drive and it’s used for a lot more than just the music files.

I get that it isn’t a NAS drive. That doesn’t necessarily stop it being attached to a router or directly to the Pi if it is a USB HDD.

So does the HDD have a separate IP address on the network, or are you entering the IP address of the Mac into Volumio? Can you ‘see’ the HDD from any other computer on the network (other than the Mac, of course)?

Sorry, I see you mentioned earlier you are entering the Mac’s IP address. Normally you enter the IP address of whatever device you have your music on. If the device doesn’t have a separate IP address then I’m not sure it will work, if you are trying to access it across the network.

You keep telling me the HDD is not a NAS, but that’s what that option in Volumio is for, mounting a NAS. That’s why it’s called ‘NAS mounts’!

It has the same IP address as the iMac and yes it can be accessed by other Macs on the network and through the File Browser app on my iPad.

Ok, so it can be accessed from within the ‘Mac’ eco-system. That figures. Within the Mac eco-system things usually do ‘just work’. It’s when you starting interfacing with non-Mac systems (like the Pi) that you might have problems.

By the way, I didn’t know what a Drobo was so I Googled it, and it appears to a family of NAS solutions! The tagline for the website (in Google) is “Drobo Data Storage Solutions, Network Attached Storage”.

My Drobo isn’t a NAS; I stupidly saved money when I bought it. Apart from the Pi I don’t have access to a non-Mac computer except my work PC, but I’m not allowed to do anything with it.

I’ve had a promise of guidance to get it working with Rune.

Ah! I see :slight_smile: The ‘poor man’s Drobo’!

Well, hopefully that will work. There does seem to be a number of people having problems connecting to their music storage (NAS or otherwise) just now in Volumio. Maybe some glitch in the current version. Talking of versions, have you tried the latest version (25th April)? … I/Beta1.3/

Yes, it’s the 1.3beta I’ve been using. Before I bought the Pi & HiFiBerry Digi I posted somewhere about what I wanted to to do and was assured that it’s possible, and I’m sure it is. The last error message I got, before I left home this morning, was that it couldn’t mount the share folder because it is read only, but it isn’t. I need to work out why volumio thinks it is.

I can’t see that it would need anything other than read-only access, if it’s just pulling music from the drive. Nor can I see see why being read-only would prevent it being mounted. Have you tried using NFS instead of SMB/CIFS? I think I’ve heard that NFS can be more problematical though.

By the way, if you look at the advanced options for the storage ‘mount’ page, it has a ‘mount flags’ section which has this in it ‘ro, noatime’.

Presumably ‘ro’ is ‘read-only’. So that may be where it is getting the ‘read-only’ from. I guess you could play with those options to see if it changes anything, although there is a warning to not mess with it unless you know what you’re doing! But I guess you’ve got nothing to lose there anyway :slight_smile:

Yes, I have tried NFS. I’ll look at the advanced settings tomorrow when I get home. I too don’t see why it would need more than read only access, but that is the reason given by Volumio for failure to mount.

I had a look at the advanced options, but don’t have the confidence to play with them.

If it’s not working anyway is it going to make any difference? It’s not as if you are going to mess up a working setup (for your HDD). However, up to you :slight_smile:

It might not change anything for the better anyway.